aboutsummaryrefslogtreecommitdiff
Do not assume the SDL_image and SLD_mixer libraries are installed at the same
prefix reported by sdl-config, but instead get flags from the pkg-config files
installed with these libraries.

--- a/SConscript	2011-12-24 15:46:47.000000000 -0600
+++ b/SConscript	2014-06-12 21:20:45.702668330 -0500
@@ -199,7 +199,13 @@
                 self.fatal_error += "  * library 'png' not found\n"
 
     def configure_sdl(self):
-        if self.conf.CheckMyProgram('sdl-config'):
+        if self.conf.CheckMyProgram('pkg-config'):
+            self.conf.env.ParseConfig("pkg-config --cflags --libs sdl")
+            for sdllib in ['image', 'mixer']:
+                self.conf.env.ParseConfig("pkg-config --cflags --libs SDL_%s" % sdllib)
+                if not self.conf.CheckSDLLib(sdllib):
+                    self.fatal_error += "  * SDL library '%s' not found\n" % sdllib
+        elif self.conf.CheckMyProgram('sdl-config'):
             self.conf.env.ParseConfig("sdl-config  --cflags --libs | sed 's/-I/-isystem/g'")
             for sdllib in ['image', 'mixer']:
                 if not self.conf.CheckSDLLib(sdllib):
2028e91252e4bdf659d1d5ad391e3a29b161291'>gnu: nano: Update to 2.9.1....Efraim Flashner 2017-11-18gnu: nano: Update to 2.9.0....Efraim Flashner 2017-08-27gnu: nano: Update to 2.8.7....Efraim Flashner 2017-07-22gnu: nano: Update to 2.8.6....Tobias Geerinckx-Rice 2017-06-25gnu: nano: Update to 2.8.5....Marius Bakke 2017-05-21gnu: nano: Update to 2.8.4....Marius Bakke 2017-05-18gnu: nano: Update to 2.8.3....Efraim Flashner 2017-05-05gnu: nano: Update to 2.8.2....Marius Bakke 2017-04-12gnu: nano: Update to 2.8.1....Efraim Flashner 2017-03-31gnu: nano: Update to 2.8.0....Efraim Flashner r> 2017-01-28tests: Adjust pypi test to recent importer change....Carlo Zancanaro 2016-12-18tests: Mock up http-fetch in import test....Ricardo Wurmus 2016-12-18tests: Mock up http-fetch in import tests....Ricardo Wurmus 2016-10-27tests: Adjust pypi test to recent importer change....Ludovic Courtès