aboutsummaryrefslogtreecommitdiff
Support the PURPLE_PLUGIN_PATH environment variable.  This patch is based on
one from Nixpkgs, but properly handles the case where that variable is unset.

--- pidgin-2.10.11/libpurple/plugin.c.orig	2014-11-23 11:41:25.000000000 -0500
+++ pidgin-2.10.11/libpurple/plugin.c	2015-08-04 14:31:02.257366144 -0400
@@ -1178,8 +1178,19 @@
 void
 purple_plugins_init(void) {
 	void *handle = purple_plugins_get_handle();
+	const gchar *purple_plugin_path;
 
 	purple_plugins_add_search_path(LIBDIR);
+	purple_plugin_path = g_getenv("PURPLE_PLUGIN_PATH");
+	if (purple_plugin_path && *purple_plugin_path) {
+		gchar **paths = g_strsplit(purple_plugin_path, ":", -1);
+		if (paths) {
+			gchar **p;
+			for (p = paths; *p; ++p)
+				if (**p) purple_plugins_add_search_path(*p);
+		}
+		g_strfreev(paths);
+	}
 
 	purple_signal_register(handle, "plugin-load",
 						 purple_marshal_VOID__POINTER,
2024-08-31gnu: gmp: Update to 6.3.0 and streamline definition....* gnu/packages/multiprecision.scm (gmp): Update to 6.3.0. Fix indentation. [arguments]: Use gexps. Remove obsolete phase. Change-Id: I99a0c8173ebc4a4a45512771ccf17782d6ddfe14 Maxim Cournoyer 2024-08-31gnu: mpfr: Update to 4.2.1....This fixes building mpfr with glibc-2.38. * gnu/packages/multiprecision.scm (mpfr): Update to 4.2.1. Change-Id: Ib8a8eecc9e72587e0fc1b8b0ee965aa274b85c7b Signed-off-by: Ludovic Courtès <ludo@gnu.org> Janneke Nieuwenhuizen 2024-03-27gnu: libtommath: Update to 1.3.0....* gnu/packages/multiprecision.scm (libtommath): Update to 1.3.0. Change-Id: If0b4758abb634f4e7564d90e8a5534ebdf6579a6 Efraim Flashner 2024-03-05gnu: libtommath: Update to 1.2.1....* gnu/packages/multiprecision.scm (libtommath): Update to 1.2.1. [source]: Remove patch. [arguments]: Remove trailing #t from phases. [properties]: Add upstream-name, lint-hidden-cve. * gnu/packages/patches/libtommath-integer-overflow.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. Change-Id: I4c1de43b4083e0649fcb493a5c304736e41ab4b8 Efraim Flashner 2024-03-05gnu: Remove libtommath-1.1....* gnu/packages/multiprecision.scm (libtommath-1.1): Delete variable. * gnu/packages/patches/libtommath-fix-linkage.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. Change-Id: I3a2bb697cbb72716756c24643920008e919889b5 Efraim Flashner 2024-03-04gnu: Remove libtommath-1.0....* gnu/packages/multiprecision.scm (libtommath-1.0): Delete variable. Change-Id: I8da3c4b16470ea24e89216644d84350e07b7dd63 Efraim Flashner