aboutsummaryrefslogtreecommitdiff
Don't long for headers and libraries in "traditional" locations.

Patch from Nixpkgs by Eelco Dolstra <eelco.dolstra@logicblox.com>.

diff -ru -x '*~' perl-5.14.2-orig/Configure perl-5.14.2/Configure
--- perl-5.14.2-orig/Configure	2011-09-26 11:44:34.000000000 +0200
+++ perl-5.14.2/Configure	2012-01-20 17:05:23.089223129 +0100
@@ -106,15 +106,7 @@
 fi
 
 : Proper PATH setting
-paths='/bin /usr/bin /usr/local/bin /usr/ucb /usr/local /usr/lbin'
-paths="$paths /opt/bin /opt/local/bin /opt/local /opt/lbin"
-paths="$paths /usr/5bin /etc /usr/gnu/bin /usr/new /usr/new/bin /usr/nbin"
-paths="$paths /opt/gnu/bin /opt/new /opt/new/bin /opt/nbin"
-paths="$paths /sys5.3/bin /sys5.3/usr/bin /bsd4.3/bin /bsd4.3/usr/ucb"
-paths="$paths /bsd4.3/usr/bin /usr/bsd /bsd43/bin /opt/ansic/bin /usr/ccs/bin"
-paths="$paths /etc /usr/lib /usr/ucblib /lib /usr/ccs/lib"
-paths="$paths /sbin /usr/sbin /usr/libexec"
-paths="$paths /system/gnu_library/bin"
+paths=''
 
 for p in $paths
 do
@@ -1311,8 +1303,7 @@
 archname=''
 : Possible local include directories to search.
 : Set locincpth to "" in a hint file to defeat local include searches.
-locincpth="/usr/local/include /opt/local/include /usr/gnu/include"
-locincpth="$locincpth /opt/gnu/include /usr/GNU/include /opt/GNU/include"
+locincpth=""
 :
 : no include file wanted by default
 inclwanted=''
@@ -1328,17 +1319,12 @@
 archobjs=''
 libnames=''
 : change the next line if compiling for Xenix/286 on Xenix/386
-xlibpth='/usr/lib/386 /lib/386'
+xlibpth=''
 : Possible local library directories to search.
-loclibpth="/usr/local/lib /opt/local/lib /usr/gnu/lib"
-loclibpth="$loclibpth /opt/gnu/lib /usr/GNU/lib /opt/GNU/lib"
+loclibpth=""
 
 : general looking path for locating libraries
-glibpth="/lib /usr/lib $xlibpth"
-glibpth="$glibpth /usr/ccs/lib /usr/ucblib /usr/local/lib"
-test -f /usr/shlib/libc.so && glibpth="/usr/shlib $glibpth"
-test -f /shlib/libc.so     && glibpth="/shlib $glibpth"
-test -d /usr/lib64         && glibpth="$glibpth /lib64 /usr/lib64 /usr/local/lib64"
+glibpth=""
 
 : Private path used by Configure to find libraries.  Its value
 : is prepended to libpth. This variable takes care of special
@@ -1371,8 +1357,6 @@
 libswanted="$libswanted m crypt sec util c cposix posix ucb bsd BSD"
 : We probably want to search /usr/shlib before most other libraries.
 : This is only used by the lib/ExtUtils/MakeMaker.pm routine extliblist.
-glibpth=`echo " $glibpth " | sed -e 's! /usr/shlib ! !'`
-glibpth="/usr/shlib $glibpth"
 : Do not use vfork unless overridden by a hint file.
 usevfork=false
 
@@ -2380,7 +2364,6 @@
 zip
 "
 pth=`echo $PATH | sed -e "s/$p_/ /g"`
-pth="$pth /lib /usr/lib"
 for file in $loclist; do
 	eval xxx=\$$file
 	case "$xxx" in
@@ -4785,7 +4768,7 @@
 : Set private lib path
 case "$plibpth" in
 '') if ./mips; then
-		plibpth="$incpath/usr/lib /usr/local/lib /usr/ccs/lib"
+		plibpth="$incpath/usr/lib"
 	fi;;
 esac
 case "$libpth" in
@@ -8390,13 +8373,8 @@
 echo " "
 case "$sysman" in
 '') 
-	syspath='/usr/share/man/man1 /usr/man/man1'
-	syspath="$syspath /usr/man/mann /usr/man/manl /usr/man/local/man1"
-	syspath="$syspath /usr/man/u_man/man1"
-	syspath="$syspath /usr/catman/u_man/man1 /usr/man/l_man/man1"
-	syspath="$syspath /usr/local/man/u_man/man1 /usr/local/man/l_man/man1"
-	syspath="$syspath /usr/man/man.L /local/man/man1 /usr/local/man/man1"
-	sysman=`./loc . /usr/man/man1 $syspath`
+	syspath=''
+	sysman=''
 	;;
 esac
 if $test -d "$sysman"; then
@@ -19721,9 +19699,10 @@
 case "$full_ar" in
 '') full_ar=$ar ;;
 esac
+full_ar=ar
 
 : Store the full pathname to the sed program for use in the C program
-full_sed=$sed
+full_sed=sed
 
 : see what type gids are declared as in the kernel
 echo " "
diff -ru -x '*~' perl-5.14.2-orig/ext/Errno/Errno_pm.PL perl-5.14.2/ext/Errno/Errno_pm.PL
--- perl-5.14.2-orig/ext/Errno/Errno_pm.PL	2011-09-26 11:44:34.000000000 +0200
+++ perl-5.14.2/ext/Errno/Errno_pm.PL	2012-01-20 17:02:07.938138311 +0100
@@ -137,11 +137,7 @@
 	if ($dep =~ /(\S+errno\.h)/) {
 	     $file{$1} = 1;
 	}
-    } elsif ($^O eq 'linux' &&
-	      $Config{gccversion} ne '' && 
-	      $Config{gccversion} !~ /intel/i
-	      # might be using, say, Intel's icc
-	     ) {
+    } elsif (0) {
 	# Some Linuxes have weird errno.hs which generate
 	# no #file or #line directives
 	my $linux_errno_h = -e '/usr/include/errno.h' ?
diff -ru -x '*~' perl-5.14.2-orig/hints/freebsd.sh perl-5.14.2/hints/freebsd.sh
--- perl-5.14.2-orig/hints/freebsd.sh	2011-09-19 15:18:22.000000000 +0200
+++ perl-5.14.2/hints/freebsd.sh	2012-01-20 17:10:37.267924044 +0100
@@ -118,21 +118,21 @@
         objformat=`/usr/bin/objformat`
         if [ x$objformat = xaout ]; then
             if [ -e /usr/lib/aout ]; then
-                libpth="/usr/lib/aout /usr/local/lib /usr/lib"
-                glibpth="/usr/lib/aout /usr/local/lib /usr/lib"
+                libpth=""
+                glibpth=""
             fi
             lddlflags='-Bshareable'
         else
-            libpth="/usr/lib /usr/local/lib"
-            glibpth="/usr/lib /usr/local/lib"
+            libpth=""
+            glibpth=""
             ldflags="-Wl,-E "
             lddlflags="-shared "
         fi
         cccdlflags='-DPIC -fPIC'
         ;;
 *)
-       libpth="/usr/lib /usr/local/lib"
-       glibpth="/usr/lib /usr/local/lib"
+       libpth=""
+       glibpth=""
        ldflags="-Wl,-E "
         lddlflags="-shared "
         cccdlflags='-DPIC -fPIC'
st clitest eudev ;just to satisfy a configure check flex) ;; For the documentation. (if (supported-package? ruby-asciidoctor) (list docbook-xml docbook-xml-4.4 ;used by documentation/ra2refentry.xsl docbook-xsl libxslt ;for xsltproc ruby-asciidoctor) '()))) (home-page "https://www.linbit.com/drbd/") (synopsis "Replicate block devices between machines") (description "@acronym{DRBD, Distributed Replicated Block Device} is a software-based, shared-nothing, replicated storage solution mirroring the content of block devices (hard disks, partitions, logical volumes etc.) over any network connection. This package contains the userland utilities.") (properties '((release-monitoring-url . "https://www.linbit.com/en/drbd-community/drbd-download/"))) (license license:gpl2+))) (define-public keepalived (package (name "keepalived") (version "2.3.1") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/acassen/keepalived") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "0mxpx5azx0m2zp757yqcavvvzg3p9nj93bczfhv6wich3wpvbwzx")))) (build-system gnu-build-system) (arguments (list #:phases #~(modify-phases %standard-phases (add-after 'build 'build-info (lambda _ (invoke "make" "-C" "doc" "texinfo") ;; Put images in a subdirectory as recommended by 'texinfo'. (install-file "doc/source/images/software_design.png" "doc/build/texinfo/keepalived-figures") (substitute* "doc/build/texinfo/keepalived.texi" (("@image\\{software_design,") "@image{keepalived-figures/software_design,")) (invoke "make" "-C" "doc/build/texinfo"))) (add-after 'install 'install-info (lambda _ (let ((infodir (string-append #$output "/share/info"))) (install-file "doc/build/texinfo/keepalived.info" infodir) (install-file "doc/source/images/software_design.png" (string-append infodir "/keepalived-figures")))))))) (native-inputs (list autoconf automake pkg-config python-sphinx texinfo)) (inputs (list openssl libnfnetlink libnl)) (home-page "https://www.keepalived.org") (synopsis "Load balancing and high-availability frameworks") (description "Keepalived provides frameworks for both load balancing and high availability. The load balancing framework relies on the Linux Virtual Server (@dfn{IPVS}) kernel module. High availability is achieved by the Virtual Redundancy Routing Protocol (@dfn{VRRP}). Each Keepalived framework can be used independently or together to provide resilient infrastructures.") (license license:gpl2+))) (define-public libraft (package (name "libraft") (version "0.11.2") (home-page "https://github.com/canonical/raft") (source (origin (method git-fetch) (uri (git-reference (url home-page) (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "050dwy34jh8dihfwfm0r1by2i3sy9crapipp9idw32idm79y4izb")))) (arguments '(#:configure-flags '("--enable-uv") #:phases (modify-phases %standard-phases (add-after 'unpack 'disable-failing-tests (lambda _ (substitute* "Makefile.am" ((".*test_uv_append.c.*") "") ((".*test_uv_tcp_connect.c.*") "")) #t))))) (inputs (list libuv lz4)) (native-inputs `(("autoconf" ,autoconf) ("automake" ,automake) ("gettext" ,gettext-minimal) ("libtool" ,libtool) ("pkg-config" ,pkg-config))) (build-system gnu-build-system) (synopsis "C implementation of the Raft consensus protocol") (description "The library has modular design: its core part implements only the core Raft algorithm logic, in a fully platform independent way. On top of that, a pluggable interface defines the I/O implementation for networking (send/receive RPC messages) and disk persistence (store log entries and snapshots).") (license license:asl2.0))) (define-public libdqlite (package (name "libdqlite") (version "1.9.0") (home-page "https://github.com/canonical/dqlite") (source (origin (method git-fetch) (uri (git-reference (url home-page) (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "0zalsvr0vy7632nhm96a29lrfy18iqsmbxpyz2lvq80mrjlbrzsn")))) (arguments '(#:phases (modify-phases %standard-phases (add-after 'unpack 'disable-failing-tests (lambda _ (substitute* "Makefile.am" ;; Test client/query sometimes fails. ;; The actual tested asserts succeed, but there appears to be a ;; race condition when tearing down the test server. ((".*test_client.c.*") ""))))))) (native-inputs (list autoconf automake libtool pkg-config)) (inputs (list libraft libuv)) (propagated-inputs (list sqlite)) ; dqlite.h includes sqlite3.h (build-system gnu-build-system) (synopsis "Distributed SQLite") (description "dqlite is a C library that implements an embeddable and replicated SQL database engine with high-availability and automatic failover.") (license license:lgpl3)))