aboutsummaryrefslogtreecommitdiff
From: Robert Luberda <robert@debian.org>
Date: Sat, 19 Nov 2016 08:48:08 +0100
Subject: Fix nullptr dereference (CVE-2016-9296)

Patch taken from https://sourceforge.net/p/p7zip/bugs/185/
This patch file taken from Debian's patch set for p7zip
---
 CPP/7zip/Archive/7z/7zIn.cpp | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/CPP/7zip/Archive/7z/7zIn.cpp b/CPP/7zip/Archive/7z/7zIn.cpp
index b0c6b98..7c6dde2 100644
--- a/CPP/7zip/Archive/7z/7zIn.cpp
+++ b/CPP/7zip/Archive/7z/7zIn.cpp
@@ -1097,7 +1097,8 @@ HRESULT CInArchive::ReadAndDecodePackedStreams(
       if (CrcCalc(data, unpackSize) != folders.FolderCRCs.Vals[i])
         ThrowIncorrect();
   }
-  HeadersSize += folders.PackPositions[folders.NumPackStreams];
+  if (folders.PackPositions)
+      HeadersSize += folders.PackPositions[folders.NumPackStreams];
   return S_OK;
 }
 
ue='20'>20space:mode:
authorLars-Dominik Braun <lars@6xq.net>2023-02-11 14:47:59 +0100
committerLars-Dominik Braun <lars@6xq.net>2023-03-19 10:57:00 +0100
commitc16add7fd9783db46bb5b308a885af62f0299e61 (patch)
tree53ddfa71f32007b8e61ae5f578038b0d2cffed38 /gnu/services/authentication.scm
parentd7b4ecdb4c1a845690d943f8b8d883e065081eb9 (diff)
downloadguix-c16add7fd9783db46bb5b308a885af62f0299e61.tar.gz
guix-c16add7fd9783db46bb5b308a885af62f0299e61.zip
gnu: python-pillow: Fix CVE-2022-45199.
Fixes: <https://issues.guix.gnu.org/issue/61172> * gnu/packages/python-xyz.scm (python-pillow/security-fixes): New variable. (python-pillow): Add replacement. * gnu/packages/patches/python-pillow-CVE-2022-45199.patch: New file. * gnu/local.mk: Register it.
Diffstat (limited to 'gnu/services/authentication.scm')
0 files changed, 0 insertions, 0 deletions