aboutsummaryrefslogtreecommitdiff
Patch inspired by file comparison with openjdk@19.

diff -u -r openjdk-10.alt/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c openjdk-10/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c
--- openjdk-10.alt/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c	2023-04-05 15:03:00.070787628 +0200
+++ openjdk-10/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c	2023-04-05 15:29:51.379824348 +0200
@@ -67,8 +67,17 @@
   longjmp(context, 1);
 }
 
-void set_signal_handler() {
-  static char altstack[SIGSTKSZ];
+static char* altstack = NULL;
+
+ void set_signal_handler() {
+  if (altstack == NULL) {
+    // Dynamically allocated in case SIGSTKSZ is not constant
+    altstack = (char*)malloc(SIGSTKSZ);
+    if (altstack == NULL) {
+      fprintf(stderr, "Test ERROR. Unable to malloc altstack space\n");
+      exit(7);
+    }
+  }
 
   stack_t ss = {
     .ss_size = SIGSTKSZ,
63ff5d6445dd393294fc6aec1f93a0d6a'>gnu: pipewire: Fix build with GCC 10....* gnu/packages/patches/pipewire-0.2.7-fno-common.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/linux.scm (pipewire)[source]: Use it. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Sarah Morgensen