aboutsummaryrefslogtreecommitdiff
This was submitted upstream
https://github.com/openbios/openbios/pull/12

diff --git a/config/scripts/switch-arch b/config/scripts/switch-arch
index b5acc6c..a96ef4b 100755
--- a/config/scripts/switch-arch
+++ b/config/scripts/switch-arch
@@ -38,7 +38,8 @@ longbits()
     if test "$cpu" = "sparc64" -o "$cpu" = "ia64" \
         -o "$cpu" = "amd64" -o "$cpu" = "x86_64" \
         -o "$cpu" = "powerpc64" -o "$cpu" = "ppc64" \
-        -o "$cpu" = "ppc64le" -o "$cpu" = "alpha" ; then
+        -o "$cpu" = "ppc64le" -o "$cpu" = "alpha" \
+        -o "$cpu" = "aarch64" -o "$cpu" = "riscv64" ; then
         echo 64
     else
         echo 32
817226'>gnu: groff: Adjust relocatability snippet for 1.22.4....This commit does three things. It reverts 73b2ce87 ("gnu: groff-minimal: Disable relocatability."), re-applies f57693e1 ("gnu: groff: Disable relocatability."), and finally adjusts the substitution for changes since 0559a4c2 ("gnu: groff: Update to 1.22.4."). * gnu/packages/groff.scm (groff-minimal)[arguments]: Move relocatibility snippet ... (groff)[arguments]: ... here. Don't delete relocation.cpp and adjust file name. Marius Bakke 2019-02-06Merge branch 'master' into core-updatesRicardo Wurmus 2019-01-17gnu: groff-minimal: Disable relocatability....* gnu/packages/groff.scm (groff-minimal)[arguments]<#:phases> [disable-relocatability]: New phase. Danny Milosavljevic 2019-01-16Revert "gnu: groff: Disable relocatability."...This causes more than 3600 packages to be rebuilt. This reverts commit f57693e17c7905d2f11e46d04cb558fe0b0fc39b. Efraim Flashner 2019-01-16gnu: groff: Disable relocatability....* gnu/packages/groff.scm (groff)[arguments]<#:phases>[disable-relocatability]: New phase. Danny Milosavljevic 2019-01-14gnu: groff: Fix doc installation....* gnu/packages/groff.scm (groff)[arguments]: Add 'fix-docdir phase. Eric Bavier 2019-01-07gnu: groff: Update to 1.22.4....* gnu/packages/groff.scm (groff): Update to 1.22.4. [source]: Remove patch. (groff-minimal)[arguments]: Update configure flags to skip documentation. * gnu/packages/patches/groff-source-date-epoch.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. Efraim Flashner 2018-05-06gnu: groff-minimal: Preserve 'preconv' executable....* gnu/packages/groff.scm (groff-minimal)[arguments]: Add 'preconv' to the list of kept programs. Marius Bakke 2017-12-06gnu: groff-minimal: Inherit phases from groff....* gnu/packages/groff.scm (groff-minimal)[arguments]: Use 'substitute-keyword-arguments' to prevent phases from "groff" overriding the phases in groff-minimal. Marius Bakke 2017-12-05Merge branch 'master' into core-updatesMarius Bakke 2017-12-02gnu: Add groff-minimal....* gnu/packages/groff.scm (groff-minimal): New variable. Ludovic Courtès 2017-08-31gnu: groff: Make build reproducible....* gnu/packages/groff.scm (groff)[arguments]: Add phase "setenv". Danny Milosavljevic 2017-07-10gnu: groff: Remove timestamps....Fixes <https://bugs.gnu.org/27593>. * gnu/packages/patches/groff-source-date-epoch.patch: New file. * gnu/local.mk: Add it. * gnu/packages/groff.scm (groff)[source]: Add it. Danny Milosavljevic 2017-07-07gnu: groff: Remove dependency on netpbm....* gnu/packages/groff.scm (groff)[inputs]: Remove 'netpbm'. Ludovic Courtès