aboutsummaryrefslogtreecommitdiff
A few tests require downloading models. Skip those.

diff --git a/onnx/backend/test/runner/__init__.py b/onnx/backend/test/runner/__init__.py
index 5b60e7c0..838c7ba5 100644
--- a/onnx/backend/test/runner/__init__.py
+++ b/onnx/backend/test/runner/__init__.py
@@ -236,6 +236,7 @@ class Runner:
             print(
                 f"Start downloading model {model_test.model_name} from {model_test.url}"
             )
+            raise unittest.SkipTest('Skipping download')
             urlretrieve(model_test.url, download_file.name)
             print("Done")
             with tarfile.open(download_file.name) as t:
-download.sh, tests/guix-environment.sh, tests/guix-gc.sh, tests/guix-git-authenticate.sh, tests/guix-graph.sh, tests/guix-hash.sh, tests/guix-lint.sh, tests/guix-pack-relocatable.sh, tests/guix-pack.sh, tests/guix-package-aliases.sh, tests/guix-package-net.sh, tests/guix-package.sh: Use the shell '!' keyword to negate command exit status in place of 'if ...; then false; else true; fi' Eric Bavier