aboutsummaryrefslogtreecommitdiff
Disable -Werror=nonnull on getcwd(0, 4096) because GCC incorrectly warns that
the second argument should be NULL with recent glibc.  See:

https://gcc.gnu.org/bugzilla/show_bug.cgi?id=96832
https://sourceware.org/bugzilla/show_bug.cgi?id=26545

diff --git a/nss/coreconf/nsinstall/nsinstall.c b/nss/coreconf/nsinstall/nsinstall.c
--- a/nss/coreconf/nsinstall/nsinstall.c
+++ b/nss/coreconf/nsinstall/nsinstall.c
@@ -236,14 +236,20 @@ main(int argc, char **argv)
 	return 0;
 
     if (!cwd) {
+#pragma GCC diagnostic push
+#pragma GCC diagnostic ignored "-Wnonnull"
 	cwd = GETCWD(0, PATH_MAX);
+#pragma GCC diagnostic pop
 	if (!cwd)
 	    fail("could not get CWD");
     }
 
     /* make sure we can get into todir. */
     xchdir(todir);
+#pragma GCC diagnostic push
+#pragma GCC diagnostic ignored "-Wnonnull"
     todir = GETCWD(0, PATH_MAX);
+#pragma GCC diagnostic pop
     if (!todir)
 	fail("could not get CWD in todir");
     tdlen = strlen(todir);
Enable VNC support....* gnu/packages/spice.scm (virt-viewer)[inputs]: Add gtk-vnc. Tobias Geerinckx-Rice 2020-10-06gnu: spice-protocol: Update to 0.14.3....* gnu/packages/spice.scm (spice-protocol): Update to 0.14.3. Tobias Geerinckx-Rice 2020-09-24gnu: spice-gtk: Only use "good" GStreamer plugins out of the box....Do not propagate plugins that are known to be patent encumbered out of the box, so the user has a choice. * gnu/packages/spice.scm (spice-gtk)[propagated-inputs]: Remove gst-libav, gst-plugins-bad and gst-plugins-ugly. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Mark H Weaver