aboutsummaryrefslogtreecommitdiff
"--enable-doc-gen" configure flag will enable HTML document generation that requires mdbook.
We can't simply disable it because we need manpages.

Author: Zhu Zihao <all_but_last@163.com>

--- a/doc/manual/local.mk
+++ b/doc/manual/local.mk
@@ -138,11 +138,6 @@
 	$(trace-gen) $(dummy-env) NIX_PATH=nix/corepkgs=corepkgs $(bindir)/nix __dump-builtins > $@.tmp
 	@mv $@.tmp $@
 
-# Generate the HTML manual.
-.PHONY: manual-html
-manual-html: $(docdir)/manual/index.html
-install: $(docdir)/manual/index.html
-
 # Generate 'nix' manpages.
 install: $(mandir)/man1/nix3-manpages
 man: doc/manual/generated/man1/nix3-manpages
@@ -167,23 +162,4 @@
 	done
 	@touch $@
 
-$(docdir)/manual/index.html: $(MANUAL_SRCS) $(d)/book.toml $(d)/anchors.jq $(d)/custom.css $(d)/src/SUMMARY.md $(d)/src/command-ref/new-cli $(d)/src/contributing/experimental-feature-descriptions.md $(d)/src/command-ref/conf-file.md $(d)/src/language/builtins.md
-	$(trace-gen) \
-		tmp="$$(mktemp -d)"; \
-		cp -r doc/manual "$$tmp"; \
-		find "$$tmp" -name '*.md' | while read -r file; do \
-			$(call process-includes,$$file,$$file); \
-		done; \
-		find "$$tmp" -name '*.md' | while read -r file; do \
-			docroot="$$(realpath --relative-to="$$(dirname "$$file")" $$tmp/manual/src)"; \
-			sed -i "s,@docroot@,$$docroot,g" "$$file"; \
-		done; \
-		set -euo pipefail; \
-		RUST_LOG=warn mdbook build "$$tmp/manual" -d $(DESTDIR)$(docdir)/manual.tmp 2>&1 \
-			| { grep -Fv "because fragment resolution isn't implemented" || :; }; \
-		rm -rf "$$tmp/manual"
-	@rm -rf $(DESTDIR)$(docdir)/manual
-	@mv $(DESTDIR)$(docdir)/manual.tmp/html $(DESTDIR)$(docdir)/manual
-	@rm -rf $(DESTDIR)$(docdir)/manual.tmp
-
 endif
title='2019-07-24 09:46:49 +0200'>2019-07-24gnu: Replace uses of texlive-*-amsfonts....* gnu/packages/algebra.scm (pari-gp)[native-inputs]: Replace texlive-fonts-amsfonts and texlive-latex-amsfonts with texlive-amsfonts in texlive-union. * gnu/packages/docbook.scm (dblatex)[inputs]: Same. * gnu/packages/plotutils.scm (asymptote)[native-inputs]: Same. * gnu/packages/python-xyz.scm (python-numpy-documentation, python-matplotlib-documentation, python-ipython-documentation) [native-inputs]: Same. * gnu/packages/statistics.scm (r-with-tests)[native-inputs]: Same. * gnu/packages/tex.scm (teximpatient)[native-inputs]: Same. Ricardo Wurmus 2019-04-16gnu: guile-charting: Install .go files in the right place....* gnu/packages/plotutils.scm (guile-charting)[source](modules, snippet): New fields. Ludovic Courtès 2019-04-04gnu: asymptote: Fix direntry in info file....* gnu/packages/plotutils.scm (asymptote): Fix direntry in info file. Nicolas Goaziou 2019-04-04gnu: Update copyright line....* gnu/packages/plotutils.scm: Update copyright line. Nicolas Goaziou 2019-04-04gnu: asymptote: Fix info file location....* gnu/packages/plotutils.scm (asymptote): Fix info file location so it appears in the top-level directory. Nicolas Goaziou 2019-04-03gnu: asymptote: Update to 2.49....* gnu/packages/plotutils.scm (asymptote): Update to 2.49. [native-inputs]: Re-order inputs. [inputs]: Update to Python 3. Add glew and glm. [arguments]: Add a phase to fix build. Remove unnecessary fix for tests. Nicolas Goaziou 2019-03-01gnu: asymptote: Remove indirect TexLive dependency....* gnu/packages/plotutils.scm (asymptote)[native-inputs]: Remove texlive-generic-ifxetex from texlive-union. Ricardo Wurmus 2018-09-06gnu: guile-charting: Install .go files to libdir....* gnu/packages/plotutils.scm (guile-charting)[source](modules, snippet): Remove. Ludovic Courtès 2018-08-21gnu: asymptote: Use minimal texlive-union....* gnu/packages/plotutils.scm (asymptote)[native-inputs]: Replace texlive with texlive-union. Pierre Neidhardt 2018-08-06gnu: asymptote: Update to 2.47....* gnu/packages/plotutils.scm (asymptote): Update to 2.47. Nicolas Goaziou