;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2020 Oleg Pykhalov ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu tests package-management) #:use-module (gnu packages base) #:use-module (gnu packages package-management) #:use-module (gnu services) #:use-module (gnu services networking) #:use-module (gnu services nix) #:use-module (gnu system) #:use-module (gnu system vm) #:use-module (gnu tests) #:use-module (guix gexp) #:use-module (guix packages) #:export (%test-nix)) ;;; Commentary: ;;; ;;; This module provides a test definition for the nix-daemon ;;; ;;; Code: (define* (run-nix-test name test-os) "Run tests in TEST-OS, which has nix-daemon running." (define os (marionette-operating-system test-os #:imported-modules '((gnu services herd)))) (define vm (virtual-machine (operating-system os) (port-forwardings '((8080 . 80))) (memory-size 1024))) (define test (with-imported-modules '((gnu build marionette)) #~(begin (use-modules (srfi srfi-11) (srfi srfi-64) (gnu build marionette) (web client) (web response)) (define marionette (make-marionette
Patch taken from Debian sid.  Adapted to 4.2.4.6 for Guix by Tobias
Geerinckx-Rice <me@tobias.gr>.

Description: Support uncompressing and compressing soft links.
 Historically, ncompress for Debian has been built using a command line
 directly in debian/rules.  For 4.2.4.5-1, I simplified by swtching to the
 upstream Makefile.  However, that caused a regression - the Debian version of
 ncompress has always successfully handled soft links, but this stopped
 working.  To revert to the original behavior, I need to remove -DLSTAT from
 the build options, to be consistent with how the code was previously built.
Author: Kenneth J. Pronovici <pronovic@debian.org>
Bug-Debian: http://bugs.debian.org/918836
Index: ncompress/GNUmakefile
===================================================================
--- ncompress.orig/GNUmakefile
+++ ncompress/GNUmakefile
@@ -9,7 +9,7 @@ distclean: cleanup
 
 Makefile: Makefile.def GNUmakefile
 	sed \
-		-e 's:options= :options= -DUTIME_H -DLSTAT :' \
+		-e 's:options= :options= -DUTIME_H :' \
 		Makefile.def > Makefile
 
 check:
"guix-test.nix"))) marionette)) (test-end) (exit (= (test-runner-fail-count (test-runner-current)) 0))))) (gexp->derivation (string-append name "-test") test)) (define %nix-os ;; Return operating system under test. (let ((base-os (simple-operating-system (service nix-service-type) (service dhcp-client-service-type)))) (operating-system (inherit base-os) (packages (cons nix (operating-system-packages base-os)))))) (define %test-nix (system-test (name "nix") (description "Connect to a running nix-daemon") (value (run-nix-test name %nix-os)))) ;;; package-management.scm ends here