aboutsummaryrefslogtreecommitdiff
Mupen64Plus supports a single data directory and a single plugin directory in
its configuration, yet we need data and plugin files from a variety of
packages.  The best way to deal with this is to install all packages from
which data and plugin files are needed into one's profile, and point the
configuration there.  Hence, the ui-console package provides propagated inputs
for packages with the most important data and plugin files, and this patch
provides the user instructions on what needs to be done in order to have
Mupen64Plus find the relevant data and plugins.

--- a/src/plugin.c
+++ b/src/plugin.c
@@ -122,6 +122,22 @@ m64p_error PluginSearchLoad(m64p_handle ConfigUI)
     {
         const char *plugindir = (*ConfigGetParamString)(ConfigUI, "PluginDir");
         lib_filelist = osal_library_search(plugindir);
+        /* Guix specific */
+        if (lib_filelist == NULL)
+        {
+            DebugMessage(M64MSG_ERROR, "No plugins found in PluginDir path: %s", plugindir);
+            DebugMessage(M64MSG_ERROR,
+                         "\n\n"
+                         "*********************************\n"
+                         "*** Notice for GNU Guix users ***\n"
+                         "*********************************\n"
+                         "\n"
+                         "You might want to edit your mupen64plus.cfg (in $XDG_CONFIG_HOME by default)\n"
+                         "and set SharedDataPath to /path/to/my_guix_profile/share/mupen64plus and\n"
+                         "PluginDir to /path/to/my_guix_profile/lib/mupen64plus so that data and plugins\n"
+                         "are found.\n"
+                         "\n");
+        }
     }
 
     /* if still no plugins found, search some common system folders */
/span>gnu: bitwise: Update to 0.43....* gnu/packages/maths.scm (bitwise): Update to 0.43. Tobias Geerinckx-Rice td>gnu: gdb: Remove Hurd patch....The patch was useful for GDB 11 on the previous Hurd version that was used; it's unnecessary on GDB 12 and GDB 11 has other build issues on the current GNU/Hurd. This change fixes "guix build gdb-minimal --target=i586-pc-gnu". * gnu/packages/patches/gdb-fix-gnu-nat-build.patch: Remove. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/gdb.scm (gdb-11)[arguments]: Remove 'patch-gdb/hurd' phase. [inputs]: Remove "hurd-build.patch" input. [supported-systems]: New field. (gdb-12)[supported-systems]: New field. Ludovic Courtès 2023-04-18gnu: gdb-minimal: Update to 12.x....* gnu/packages/gdb.scm (gdb-minimal): Rebase on GDB-12. Ludovic Courtès 2023-04-18gnu: gdb: Use 'cross-mig' when targeting GNU/Hurd....This is a followup to 2756d662aa27cf55f3224e4a0a9e08c1be2cc551. * gnu/packages/gdb.scm (gdb-11)[native-inputs]: Use 'cross-mig' instead of 'mig/32-bit'. Ludovic Courtès 2022-11-07gnu: Add avr-gdb....* gnu/packages/gdb.scm (avr-gdb): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net> Kristian Lein-Mathisen 2022-08-03gnu: Add gdb-12....* gnu/packages/gdb.scm (gdb-12): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan