aboutsummaryrefslogtreecommitdiff
Avoid the default dynamic executable, which depends on minisat.so
Instead install the release version, which is statically linked.

diff --git a/Makefile b/Makefile
index ceb9d77..7b91906 100644
--- a/Makefile
+++ b/Makefile
@@ -191,9 +191,9 @@ install-lib: $(BUILD_DIR)/release/lib/$(MINISAT_SLIB) $(BUILD_DIR)/dynamic/lib/$
 	ln -sf $(MINISAT_DLIB).$(SOMAJOR) $(DESTDIR)$(libdir)/$(MINISAT_DLIB)
 	$(INSTALL) -m 644 $(BUILD_DIR)/release/lib/$(MINISAT_SLIB) $(DESTDIR)$(libdir)
 
-install-bin: $(BUILD_DIR)/dynamic/bin/$(MINISAT)
+install-bin: $(BUILD_DIR)/release/bin/$(MINISAT)
 	$(INSTALL) -d $(DESTDIR)$(bindir)
-	$(INSTALL) -m 755 $(BUILD_DIR)/dynamic/bin/$(MINISAT) $(DESTDIR)$(bindir)
+	$(INSTALL) -m 755 $(BUILD_DIR)/release/bin/$(MINISAT) $(DESTDIR)$(bindir)
 
 clean:
 	rm -f $(foreach t, release debug profile dynamic, $(foreach o, $(SRCS:.cc=.o), $(BUILD_DIR)/$t/$o)) \
7gnu: pkg-config: Fix typo in search paths....* gnu/packages/pkg-config.scm (pkg-config-for-build)[native-search-paths]: Use "PKG_CONFIG_PATH_FOR_BUILD" instead of "PKG_CONFIG_PATH". Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Maxime Devos 2021-09-20gnu: Add pkg-config-for-build....* gnu/packages/pkg-config.scm (pkg-config-for-build): New variable. Maxime Devos 2019-11-16Merge remote-tracking branch master into core-updatesMathieu Othacehe 2019-11-07gnu: pkg-config: Memoize 'cross-pkg-config'....When running: guix build --target=arm-linux-gnueabihf gdb -nd this reduces the number of hits in the 'add-data-to-store' cache from 205 (25%) to 163 (21%). * gnu/packages/pkg-config.scm (cross-pkg-config): Turn into an 'mlambda'. Ludovic Courtès 2019-09-24gnu: pkg-config: Fix cross-compilation....* gnu/packages/pkg-config.scm (%pkg-config)[arguments]: Add configure-flags to disable tests that fail when cross-compiling. Mathieu Othacehe