aboutsummaryrefslogtreecommitdiff
The VTK_MAJOR_VERSION macro is not available by default in newer versions.
This is a hack to expose it without changing all imports.

diff --git a/addons/vtk/CMakeLists.txt b/addons/vtk/CMakeLists.txt
--- a/addons/vtk/CMakeLists.txt
+++ b/addons/vtk/CMakeLists.txt
@@ -36,6 +36,8 @@ IF(WITH_VTKIO)
     ELSE()
       SET(SELECTED_VTK_LIBS ${VTK_MODULES_REQUESTED})
     ENDIF()
+
+   add_compile_definitions(VTK_MAJOR_VERSION=${VTK_VERSION_MAJOR})
     
     SET(VTK_LINK_LIBS_MESH ${SELECTED_VTK_LIBS} miamesh)
     SET(VTK_LINK_LIBS_3D ${SELECTED_VTK_LIBS} mia3d)
patches/ghc-memory-fix-32bit.patch?id=a14a94deb218f459dc8a3139ef6e25f15c822463&showmsg=1'>Expand)Author 2023-11-15gnu: ghc-memory: Fix building on i686-linux....* gnu/packages/haskell-xyz.scm (ghc-memory)[source]: Add patch. * gnu/packages/patches/ghc-memory-fix-32bit.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: I8dc7a13a94ce37021ad402b4e2d0cd061220f670 Efraim Flashner