aboutsummaryrefslogtreecommitdiff
This patch from resolution of https://sourceforge.net/p/mhash/bugs/37/

--- a/src/keygen_test.c
+++ b/src/keygen_test.c
@@ -121,8 +121,6 @@
 	
 	mhash_keygen_ext(KEYGEN_S2K_SALTED, data, key, keysize, password, passlen);
 
-	mutils_memset(tmp, 0, keysize * 2);
-
 	tmp = mutils_asciify(key, keysize);
 
 	result = mutils_strcmp((mutils_word8 *) KEY2, tmp);
Remove task from 'guix-daemon.conf'....Christopher Baines 2017-05-04etc: indent-code.el: Define source tree by "indent-code.el"....Alex Kost 2017-04-22Increase "TasksMax" in 'guix-daemon.service'....Sergei Trofimovich 2017-03-06build: Don't embed absolute paths in .service and .conf service files....Leo Famulari 2017-02-08etc: The pre-push hook says which commits failed the signature check....Leo Famulari 2017-02-07bash completion: Complete subcommands for the current word....Ludovic Courtès 2017-02-07bash completion: Properly complete 'guix container exec'....Ludovic Courtès 2017-02-07bash completion: Complete file names after 'guix system COMMAND'....Ludovic Courtès 2017-02-07bash completion: Complete 'guix gc' with file names....Ludovic Courtès 2017-01-20etc: indent-code.el: Add indentation info for non-Guix Scheme constructs....Ludovic Courtès 2017-01-13etc: Support indentation of whole files....Ludovic Courtès 2017-01-12etc: Add 'indent-package.el' script....Ludovic Courtès 2017-01-04doc: Add a Git hook that verifies signatures before pushing....Leo Famulari 2016-11-24Add system start-up files for "guix publish"....Hartmut Goebel 2016-09-07bash completion: Complete subcommands and their options....Ludovic Courtès 2016-09-07bash completion: Redirect 'guix' stderr to /dev/null....Ludovic Courtès 2016-09-07Add Zsh completion file....Eric Le Bihan 2016-07-18Set "GUIX_LOCPATH" in 'guix-daemon.service'....Ricardo Wurmus 2016-04-25Add "TasksMax=1024" in 'guix-daemon.service'....Ludovic Courtès 2015-11-26Add 'guix-daemon.conf' job for Upstart....Mario Daniel Ruiz Saavedra