aboutsummaryrefslogtreecommitdiff
Remove dependencies on xwin and zig.  We're not offering cross-compilation
options using these crates.

diff --git a/Cargo.toml b/Cargo.toml
index 24305db..c7641f9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -95,16 +95,6 @@ version = "0.1.24"
 [dependencies.cargo-options]
 version = "0.7.2"
 
-[dependencies.cargo-xwin]
-version = "0.18.3"
-optional = true
-default-features = false
-
-[dependencies.cargo-zigbuild]
-version = "0.19.7"
-optional = true
-default-features = false
-
 [dependencies.cargo_metadata]
 version = "0.19.0"
 
@@ -364,10 +354,6 @@ version = "7.0.0"
 
 [features]
 cli-completion = ["dep:clap_complete_command"]
-cross-compile = [
-    "zig",
-    "xwin",
-]
 default = [
     "full",
     "rustls",
@@ -375,7 +361,6 @@ default = [
 faster-tests = []
 full = [
     "cli-completion",
-    "cross-compile",
     "scaffolding",
     "upload",
 ]
@@ -384,7 +369,6 @@ log = []
 native-tls = [
     "dep:native-tls",
     "ureq?/native-tls",
-    "cargo-xwin?/native-tls",
     "dep:rustls-pemfile",
 ]
 password-storage = [
@@ -394,7 +378,6 @@ password-storage = [
 rustls = [
     "dep:rustls",
     "ureq?/tls",
-    "cargo-xwin?/rustls-tls",
     "dep:rustls-pemfile",
 ]
 scaffolding = [
@@ -416,5 +399,3 @@ upload = [
     "wild",
     "dep:dirs",
 ]
-xwin = ["cargo-xwin"]
-zig = ["cargo-zigbuild"]