aboutsummaryrefslogtreecommitdiff

1aa061c46a9f2680084c&showmsg=1'>ci.scm
AgeCommit message (Collapse)Author
2024-07-10gnu: ci: Cross-build for fewer platforms.Efraim Flashner
* gnu/ci.scm (%unsupported-platform-triplets): New variable. (cross-jobs): Also don't build for systems listed in %unsupported-platform-triplets. Change-Id: Ic31ae6d307f2d243c098ec050bdb9d09060466ac
2024-06-13ci: Add cross-compilation jobs for x86_64-linux-gnux32.Ludovic Courtès
* gnu/ci.scm (cross-jobs)[same?]: Special case x86_64-linux-gnux32. Change-Id: I877eb50d6b0b0bf10474c58f8e9d5ee92f1705d2
2024-05-31ci: Build visionfive2-barebones-raw-image.Zheng Junjie
* gnu/ci.scm (%guix-system-images): Add visionfive2-barebones-raw-image. Change-Id: I0a0edccf00119d6b23b864bb0123be6ca7b01d34 Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
2024-04-17ci: Don’t cross-compile to xtensa-ath9k-elf.Ludovic Courtès
This is a followup to 9a60894156c3ea2c609ae0cd787df949f2d6ecc2. * gnu/ci.scm (%bare-platform-triplets): New variable. (cross-jobs)[pointless?]: Use it. Change-Id: I4701bc402bb93d372d46b7208697e0f998a1dc62
2024-01-23ci: Don't cross compile to or1k-elf.Mathieu Othacehe
* gnu/ci.scm (cross-jobs)[pointless?]: Don't build any packages for or1k-elf. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Change-Id: I294429d5318b94fb8e7780a37f3608b5321cf6ca
2023-12-18gnu: ci: Build tuned packages for common baselines.Efraim Flashner
* gnu/ci.scm (%x86-64-micro-architectures): Update the list of micro-architectures to also match the psABI levels. Change-Id: Iee2f65376a00ad2ee5fb393c2e64c07f866d8116
2023-12-12ci: Don't cross compile to avr.Efraim Flashner
* gnu/ci.scm (cross-jobs)[pointless?]: Don't build any packages for avr. Change-Id: I1728727874d65461b82364e71b70c7d1fd050d90
2023-09-20image: Introduce the mbr-hybrid-raw image type.Mathieu Othacehe
Until 209204e23b39af09e0ea92540b6fa00a60e6a0ae and d57cab764122af69d52d8cc9c843456044e5d7bc, the default image type used by "guix system image" was an MBR image with an ESP partition. Having both an MBR image and an ESP partition is handy because the image will boot on most x86 based systems using legacy BIOS and/or UEFI. We now have a distinction between MBR images and EFI images. Introduce a new MBR hybrid image type and default to it to restore the default behaviour. This also fixes the images section of (gnu ci) that was trying to install a BIOS bootloader on an EFI, GPT image and failing to do so. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
2023-08-21ci: Really honor system type for manifests.Ludovic Courtès
* gnu/ci.scm (manifests->jobs): Pass SYSTEM to 'lower-object'.
2023-08-21ci: Honor user-specific systems for manifests.Ludovic Courtès
* gnu/ci.scm (manifests->jobs): Add 'systems' argument. [manifest-entry->job]: Add 'system' and honor it. Honor it. (cuirass-jobs): Pass SYSTEMS to 'manifests->jobs'.
2023-08-18gnu: commencement: Use system in %final-inputs.Christopher Baines
Otherwise this causes odd issues, I presume arising from when %current-system differs from the system argument passed to %final-inputs. * gnu/packages/commencement.scm (%final-inputs): Set %current-system to system. * gnu/packages/base.scm (%final-inputs): Add optional system parameter. * gnu/ci.scm (base-packages): New procedure to memoize the base packages depending on system. (package->job): Pass system to base-packages. Co-authored-by: Josselin Poiret <dev@jpoiret.xyz> Signed-off-by: Josselin Poiret <dev@jpoiret.xyz> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2023-04-18ci: Add 'gdb-minimal' to the "core" package set.Ludovic Courtès
* gnu/ci.scm (%core-packages): Add GDB-MINIMAL.
2023-03-09ci: Update the list of GCC versions for the 'core' subset.Ludovic Courtès
* gnu/ci.scm (%core-packages): Remove GCC-8 and GCC-9. Add GCC-12.
2022-10-22Remove now unnecessary uses of (guix grafts).Ludovic Courtès
These modules would use (guix grafts) just to access '%graft?' and related bindings, which are now in (guix store). * gnu/ci.scm, guix/gexp.scm, guix/lint.scm, guix/scripts.scm, guix/scripts/archive.scm, guix/scripts/build.scm, guix/scripts/challenge.scm, guix/scripts/deploy.scm, guix/scripts/environment.scm, guix/scripts/home.scm, guix/scripts/pack.scm, guix/scripts/package.scm, guix/scripts/pull.scm, guix/scripts/size.scm, guix/scripts/system.scm, guix/scripts/weather.scm, tests/builders.scm, tests/channels.scm, tests/cpan.scm, tests/derivations.scm, tests/gexp.scm, tests/graph.scm, tests/guix-daemon.sh, tests/monads.scm, tests/pack.scm, tests/packages.scm, tests/profiles.scm, tests/system.scm: Remove #:use-module (guix grafts).
2022-10-13ci: Honor the system passed to image->job.Mathieu Othacehe
Fixes: <https://issues.guix.gnu.org/53480>. * gnu/ci.scm (image->job): Pass the system argument to the underlying lower-object call.
2022-10-11Revert "guix system: Remove unused 'read-operating-system' procedure."Ludovic Courtès
This reverts commit d11a432adffe9308eafec6b77cddd3145029109e. The 'read-operating-system' is used in Emacs-Guix.
2022-09-24gnu: Add compression module.Mathieu Othacehe
Move the compression record to a dedicated module so that it can be used outside (guix scripts pack) module. * guix/scripts/pack.scm (<compressor>, %compressors, lookup-compressor): Move it to ... * gnu/compression.scm: ... this new file. * gnu/ci.scm: Adapt it. * local.mk (GNU_SYSTEM_MODULES): Add it.
2022-08-17ci: Fix the images specification.Mathieu Othacehe
If the current-guix-package parameter is not set, Cuirass will try to update the in-store Git checkout used by the evaluate.scm inferior: ice-9/boot-9.scm:1685:16: In procedure raise-exception: ERROR: 1. &inferior-exception: arguments: (git-error #<inferior-object #<<git-error> code: -3 message: "could not find repository from '/gnu/store/v33m82qzkvd96dlp2g83dvz62n4pkad2-guix-20d8081'" class: 6>>) inferior: #<inferior pipe (0 1 1) 7f7948957dc0> stack: ((#f ("ice-9/boot-9.scm" 1779 13)) (raise-exception ("ice-9/boot-9.scm" 1682 16)) (raise-exception ("ice-9/boot-9.scm" 1684 16)) (#f ("guix/git.scm" 395 13)) This is a follow-up of: 5bce4c82422de6beb3ce6120ba1592be898c2b72. * gnu/ci.scm (image-jobs): Add source and commit arguments. Use them to set the current-guix-package parameter. (cuirass-jobs): Adapt accordingly.
2022-08-09build-system: Add 'channel-build-system'.Ludovic Courtès
* gnu/ci.scm (channel-build-system, channel-source->package): Remove. * gnu/packages/package-management.scm (channel-source->package): New procedure, moved from (gnu ci). * guix/build-system/channel.scm: New file, with code moved from (gnu ci). * doc/guix.texi (Build Systems): Document it.
2022-08-05guix system: Remove unused 'read-operating-system' procedure.Ludovic Courtès
* guix/scripts/system.scm (read-operating-system): Remove. * gnu/ci.scm: Remove unused (guix scripts system) import.