aboutsummaryrefslogtreecommitdiff
From: Enrico Tassi <gareuselesinge@debian.org>
Date: Tue, 26 Aug 2014 16:20:55 +0200
Subject: Fix stack overflow in vararg functions

---
 src/ldo.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/src/ldo.c b/src/ldo.c
index d1bf786..30333bf 100644
--- a/src/ldo.c
+++ b/src/ldo.c
@@ -274,7 +274,7 @@ int luaD_precall (lua_State *L, StkId func, int nresults) {
     CallInfo *ci;
     StkId st, base;
     Proto *p = cl->p;
-    luaD_checkstack(L, p->maxstacksize);
+    luaD_checkstack(L, p->maxstacksize + p->numparams);
     func = restorestack(L, funcr);
       base = func + 1;
il'>...* gnu/packages/freeipmi.scm (freeipmi): Update to 1.6.6. Tobias Geerinckx-Rice 2020-05-22gnu: freeipmi: Don't build static libraries....This shrinks the size of the package by about 33%. * gnu/packages/freeipmi.scm (freeipmi)[arguments]: Add configure-flag to disable static libraries. Efraim Flashner 2020-05-22gnu: freeipmi: Update to 1.6.5....* gnu/packages/freeipmi.scm (freeipmi): Update to 1.6.5. Efraim Flashner