aboutsummaryrefslogtreecommitdiff
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Mon, 23 Nov 2020 05:36:53 +0100
Subject: [PATCH] gnu: lsof: Make test failures fatal.

Submitted upstream[0].

[0]: https://github.com/lsof-org/lsof/pull/144

diff --git a/tests/Makefile b/tests/Makefile
index 08574a0..2923bb8 100644
--- a/tests/Makefile
+++ b/tests/Makefile
@@ -27,7 +27,7 @@ all:	${CKTSTDB} ${BASTST} ${STDTST} FRC
 	  exit 1 ;\
 	fi
 	@rm -f config.LT*
-	-@err=0; \
+	@err=0; \
 	echo ""; \
 	echo "Basic test:"; \
 	./${BASTST}; \
@@ -54,8 +54,11 @@ all:	${CKTSTDB} ${BASTST} ${STDTST} FRC
 	    echo "Suggestion: try the optional tests: \"make opt\""; \
 	    echo ""; \
 	  fi; \
-	fi;
-	@rm -f config.LT*
+	fi; \
+	rm -f config.LT*; \
+	if [ $$err -ne 0 ]; then \
+	  exit 1; \
+	fi
 
 auto:	ckDB silent FRC
 
@@ -112,7 +115,7 @@ LTunix: LTunix.c ${CONFIG} ${LIBOBJ} ${HDR} config.ldflags
 
 opt:	${CKTSTDB} ${OPTTST} FRC
 	@rm -f config.LT*
-	-@err=0; \
+	@err=0; \
 	echo ""; \
 	echo "Optional tests:"; \
 	for i in ${OPTTST}; do \
@@ -126,8 +129,11 @@ opt:	${CKTSTDB} ${OPTTST} FRC
 	else \
 	  echo "All optional tests succeeded."; \
 	fi; \
-	echo "";
-	@rm -f config.LT*
+	echo ""; \
+	rm -f config.LT*; \
+	if [ $$err -ne 0 ]; then \
+	  exit 1; \
+	fi
 
 optional: opt
 
/packages/patches/aws-c-auth-cmake-prefix.patch, gnu/packages/patches/aws-c-auth-disable-networking-tests.patch: Delete files. * gnu/local.mk: Add and remove them. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan gnu: samba: Update to 4.13.2....* gnu/packages/samba.scm (samba): Update to 4.13.2. Tobias Geerinckx-Rice 2020-11-03gnu: samba: Prepare for tests....* gnu/packages/samba.scm (samba)[arguments]: Update comment regarding the test suite failure. [make-flags]: Run the test suite with the '--quick' option, as it is very slow otherwise. [phases]{configure}: Add the '--enable-selftest' argument. [inputs]: Add libtirpc. Maxim Cournoyer 2020-11-03gnu: samba: Unbundle cmocka, heimdal; add gamin....* gnu/packages/samba.scm (samba)[snippet]: Update comment. [phases]{configure}: Remove '--bundled-libraries=com_err' argument. [inputs]: Add cmocka, heimdal, gamin. Remove TODO comment. Maxim Cournoyer 2020-11-03gnu: samba: Set localstatedir to /var....It previously defaulted to a $PREFIX/var, where $PREFIX was the root of the installation directory (under /gnu/store) of Samba. * gnu/packages/samba.scm (samba)[phases]{configure}: Add --localstatedir=/var option. {disable-etc-samba-directory-creation}: Rename to disable-etc,var-samba-directories-setup and prevent creating directories under both sysconfdir and localstatedir. Maxim Cournoyer 2020-11-03gnu: samba: Update to 4.13.1....* gnu/packages/samba.scm (samba): Update to 4.13.1. [native-inputs]: Add libxml2. [phases]{locate-docbook-stylesheets}: Rename to... {setup-docbook-stylesheets}: ...this. Setup offline Samba DTD catalog, and have it used along any pre-existing XML_CATALOG_FILES environment variable in the build script. Maxim Cournoyer 2020-09-22gnu: samba: Fix fcntl hint detection in configure script....The configure script generates a C program to detect support for lifetime hints on files. But this program could crash, potentially leaving a stale unreadable file behind which could cause the patch-generated-file-shebang phase to fail. Reported upstream <https://bugzilla.samba.org/show_bug.cgi?id=14503>. * gnu/packages/patches/patches/samba-fix-fcntl-hint-detection.patch: New file. * gnu/packages/samba.scm (samba)[origin]: Add patch. * gnu/local.mk (dist_patch_DATA): Register patch. Pierre Langlois 2020-09-21gnu: samba: Update to 4.12.7 [security fixes]....Fixes CVE-2020-1472 with 4.12.7. Fixes CVE-2020-10730, CVE-2020-10745, CVE-2020-10760 and CVE-2020-14303 with 4.12.4. * gnu/packages/samba.org (samba): Update to 4.12.7. Pierre Langlois 2020-09-04gnu: cifs-utils: Update to 6.11 [fixes CVE-2020-14342]....* gnu/packages/samba.scm (cifs-utils): Update to 6.11. Tobias Geerinckx-Rice 2020-06-02gnu: iniparser: Edit synopsis & description....* gnu/packages/samba.scm (iniparser)[synopsis, description]: Flesh out. Tobias Geerinckx-Rice 2020-06-02gnu: iniparser: Fix cross-compilation....* gnu/packages/samba.scm (iniparser)[arguments]: Use CC-FOR-TARGET. Tobias Geerinckx-Rice 2020-06-02gnu: samba: Update to 4.12.3....* gnu/packages/samba.scm (samba): Update to 4.12.3. Tobias Geerinckx-Rice 2020-05-13gnu: samba: Update to 4.12.2....* gnu/packages/samba.scm (samba): Update to 4.12.2. [source]: Remove bundled python-iso8601 in a snippet. [native-inputs]: Add perl-parse-yapp, python-iso8601, and docbook-xml-4.2. Move perl and python… [inputs]: …to their proper home and remove libaio. Tobias Geerinckx-Rice 2020-05-13gnu: samba: Remove obsolete iniparser input....* gnu/packages/samba.scm (samba)[inputs]: Remove iniparser. Tobias Geerinckx-Rice 2020-05-11gnu: samba: Update to 4.11.9....* gnu/packages/samba.scm (samba): Update to 4.11.9. Tobias Geerinckx-Rice 2020-05-10gnu: samba: Update to 4.11.8 [fixes CVE-2020-10700, CVE-2020-10704]....* gnu/packages/samba.scm (samba): Update to 4.11.8. Tobias Geerinckx-Rice