aboutsummaryrefslogtreecommitdiff
This patch was downloaded from https://sft.its.cern.ch/jira/browse/ROOT-7047.
It fixes the build of clang 3.5 with GCC 5.  File paths have been adjusted.

From 00f3ed6eee41da871799ad0fd19153c7682d61fe Mon Sep 17 00:00:00 2001
From: Alexander Klimov <alserkli@inbox.ru>
Date: Mon, 26 Jan 2015 18:45:23 +0200
Subject: [PATCH] [ADT/IntrusiveRefCntPtr] Give friend access to
 IntrusiveRefCntPtr<X> so the relevant move constructor can
 access 'Obj'.

From LLVM upstream:
Author: Argyrios Kyrtzidis <akyrtzi@gmail.com>
Date:   Tue Sep 23 06:06:43 2014 +0000
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@218295 91177308-0d34-0410-b5e6-96231b3b80d8
---
 interpreter/llvm/src/include/llvm/ADT/IntrusiveRefCntPtr.h |    3 +++
 1 file changed, 3 insertions(+)

diff --git a/include/llvm/ADT/IntrusiveRefCntPtr.h b/include/llvm/ADT/IntrusiveRefCntPtr.h
index f9df378..c859c98 100644
--- a/include/llvm/ADT/IntrusiveRefCntPtr.h
+++ b/include/llvm/ADT/IntrusiveRefCntPtr.h
@@ -197,6 +197,9 @@ public:
   private:
     void retain() { if (Obj) IntrusiveRefCntPtrInfo<T>::retain(Obj); }
     void release() { if (Obj) IntrusiveRefCntPtrInfo<T>::release(Obj); }
+
+    template <typename X>
+    friend class IntrusiveRefCntPtr;
   };
 
   template<class T, class U>
-- 
1.7.10.4

ellseher <sharlatanus@gmail.com> Sebastian Gibb 2024-07-30gnu: python-pytest-openfiles: Simplify package....* gnu/packages/python-check.scm (python-pytest-openfiles) [build-system]: Swap to pyproject-build-system. [arguments]: <#:phases>: Use default 'chck phase. Change-Id: I3bbbacd8694afdfee020f11d37f5c035bdad73f9 Sharlatan Hellseher 2024-07-30gnu: python-pytest-openfiles: Update to 0.6.0....* gnu/packages/python-check.scm (python-pytest-openfiles): Update to 0.6.0. Change-Id: I629c0b1ad56c313a850cbca6f58e66bb1d9920d7 Sharlatan Hellseher 2024-07-16gnu: python-pytest-trio: Move to pyproject-build-system....* gnu/packages/python-check.scm (python-pytest-trio): [build-system]: Move to pyproject-build-system. [arguments]: Move from <#:phases> to <#test-flags>. Change-Id: I7653110fc299d0757f7e01c2c1c29d599cb206bf Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Signed-off-by: jgart <jgart@dismail.de> Nicolas Graves 2024-07-03gnu: python-pytest-sanic: Further relax the websockets version requirements....* gnu/packages/python-check.scm (python-pytest-sanic)[arguments]: Accept PYTHON-WEBSOCKETS 12.0 in the custom 'relax-requirements' phase. Change-Id: I279d7f98ff2f1fe3be46ffd4f06bbc3005c453b5 Leo Famulari 2024-06-26gnu: Add python-pytest-subprocess....* gnu/packages/python-check.scm (python-pytest-subprocess): New variable. Change-Id: Id651d945836879e71eb30f51bc392f3027bcad6e Signed-off-by: jgart <jgart@dismail.de> Vinicius Monego 2024-06-18gnu: Add python-pytest-rerunfailures-13....* gnu/packages/python-check.scm (python-pytest-rerunfailures-13): New variable. David Elsing 2024-06-18gnu: Add python-expecttest....* gnu/packages/python-check.scm (python-expecttest): New variable. David Elsing 2024-06-18gnu: Add python-pytest-shard....* gnu/packages/python-check.scm (python-pytest-shard): New variable. David Elsing 2024-06-18gnu: Add python-pytest-flakefinder....* gnu/packages/python-check.scm (python-pytest-flakefinder): New variable. David Elsing 2024-05-05gnu: python-pytest-shutil: Disable a test....* gnu/packages/python-check.scm (python-pytest-shutil)[build-system]: Use pyproject-build-system. [arguments]: Disable test_pretty_formatter. Change-Id: I862320feab5b3c6e375bf652deced6a631dfc575 Ricardo Wurmus 2024-05-05gnu: Add python-nbmake....* gnu/packages/python-check.scm (python-nbmake): New variable. Change-Id: If062d0e34329e99b5bb87588e7ddf149c65bfdfb Ricardo Wurmus 2024-04-30gnu: Add python-assay....* gnu/packages/python-check.scm (python-assay): New variable. Change-Id: I0ec910d8c37000ff08119a33e3f42af2269fa494 Sharlatan Hellseher 2024-04-30gnu: python-pytest-socket: Update to 0.7.0....* gnu/packages/python-check.scm (python-pytest-socket): Update to 0.7.0. Change-Id: I879064eba2f4d93d2e2b519ebdf613685d5b5df9 Sharlatan Hellseher 2024-03-29gnu: python-pytest-filter-subpackage: Update to 0.2.0....* gnu/packages/python-check.scm (python-pytest-filter-subpackage): Update to 0.2.0. Change-Id: I04f000b3a75f671340fbd351b06265b99acb3856 Sharlatan Hellseher 2024-03-29gnu: python-pytest-arraydiff: Enable tests....* gnu/packages/python-check.scm (python-pytest-arraydiff): Enable tests. [build-system]: Swap to pyproject-build-system. [arguments] <#:test-flags>: Disable tests requiring python-astropy to break dependencies cycle. Change-Id: I0e4b6681d106a999c6fc12c3fd8c8f084762a92e Sharlatan Hellseher 2024-03-29gnu: python-pytest-arraydiff: Update to 0.6.1....* gnu/packages/python-check.scm (python-pytest-arraydiff): Update to 0.6.1. Change-Id: I6dd911eb38597790f66756a77f6086112329a156 Sharlatan Hellseher 2024-03-29gnu: python-pytest-doctestplus: Update to 1.2.0....* gnu/packages/python-check.scm (python-pytest-doctestplus): Update to 1.2.0. [arguments] <#:test-flags>: Disable one more failing test. [home-page]: Update accordingly with lint warning. Change-Id: I353a671741cf887c348d627d9e071e3fedcc4edc Sharlatan Hellseher 2024-03-28gnu: Add python-pytest-testmon....* gnu/packages/python-check.scm (python-pytest-testmon): New variable. Change-Id: Ia2e6034781898c04bd766145e0352060a975d479 Signed-off-by: Ricardo Wurmus <rekado@elephly.net> nafkhamdc 2024-02-11gnu: python-pytest-socket: Simplify package, enable tests....* gnu/packages/python-check.scm (python-pytest-socket) [build-system]: Swap to pyproject-build-system. [arguments] <#:test-flags>: Disable tests requiring network access. <#:phases>: Use standard phases. Change-Id: Ib7fe0b3dab4e269c00856a10b8ca23acc8c8e180 Sharlatan Hellseher 2024-02-11gnu: python-pyinstrument: Enable tests....* gnu/packages/python-check.scm (python-pyinstrument) [build-system]: Swap to pyproject-build-system. [native-inputs]: Add python-greenlet. Change-Id: I1cd0c3e906fbbdc561e66bae9fe35333f61801cf Sharlatan Hellseher 2024-02-11gnu: python-pyinstrument: Update to 4.6.2....* gnu/packages/python-check.scm (python-pyinstrument): Update to 4.6.2. Change-Id: I28e147272f273c04f7221f6d4f70677aee9a3747 Sharlatan Hellseher 2024-02-11gnu: python-pytest-csv: Simplify package....* gnu/packages/python-check.scm (python-pytest-csv) [build-system]: Swap to pyproejct-build-system. [arguments]: Use standard 'check phase. Change-Id: Iae04747b117bf5b5f9fb3c8b57cd40b8822edd77 Sharlatan Hellseher 2024-02-11gnu: python-beartype: Simplify package....* gnu/packages/python-check.scm (python-beartype) [build-system]: Swap to pyproject-build-system. [arguments]: Use standard 'check phase and <#:test-flags>. Change-Id: I372c5be3b142f0e25d15fd2bac20fc9cd4d8030c Sharlatan Hellseher 2024-02-11gnu: Add python-pandas-vet....* gnu/packages/python-xyz.scm (python-pandas-vet): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Troy Figiel 2024-01-11gnu: python-pytest-sanic: Relax requirement on websockets....* gnu/packages/python-check.scm (python-pytest-sanic)[arguments]: Use plain list; add 'relax-requirements phase. [description]: Use complete sentence. Change-Id: I3c21380b4aa208da8a92270b6748b620a4a2dcc0 Ricardo Wurmus 2023-12-28gnu: Add python-pytest-cookies....* gnu/packages/python-check.scm (python-pytest-cookies): New variable. Change-Id: I0b085d345bf1bce5fc9c03315da06954cf2125cb Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Troy Figiel