aboutsummaryrefslogtreecommitdiff
--- a/include/utils/StrongPointer.h	2018-04-25 18:42:34.321003602 +0200
+++ b/include/utils/StrongPointer.h	2018-04-25 18:42:42.180912201 +0200
@@ -17,8 +17,6 @@
 #ifndef ANDROID_STRONG_POINTER_H
 #define ANDROID_STRONG_POINTER_H
 
-#include <cutils/atomic.h>
-
 #include <stdint.h>
 #include <sys/types.h>
 #include <stdlib.h>
--- a/libutils/Trace.cpp	2018-04-25 20:41:48.775049786 +0200
+++ b/libutils/Trace.cpp	2018-04-25 20:42:13.674744182 +0200
@@ -21,5 +21,7 @@
 
 static void traceInit()
 {
+#if defined(__ANDROID__)
     ::android::add_sysprop_change_callback(atrace_update_tags, 0);
+#endif
 }
f2bbc1602&showmsg=1'>Expand)Author 2022-01-07gnu: xpra: Update to 4.3.1....Fixes: <https://issues.guix.gnu.org/52869>. * gnu/packages/xorg.scm (xpra): Update to 4.3.1. [inputs]: Add libxres. * gnu/packages/patches/xpra-4.2-install_libs.patch: Adjust to updated setup.py. Lars-Dominik Braun 2022-01-07gnu: xpra: Install Cython-built libraries....xpra would fail to start, because shared objects were not installed. It’s not clear why it stopped working, but it seems it was not the upgrade I reverted in commit ab6d56d01d62757caa66fe0a23e8864c9122f0e6 to fix #52869. Sorry for the confusion :( * gnu/packages/patches/xpra-4.2-install_libs.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/xorg.scm (xpra)[source]: Add new patch. [arguments]: Ensure 'build phase runs and passes #:configure-flags to setup.py. Lars-Dominik Braun