aboutsummaryrefslogtreecommitdiff
diff --git a/libusb/descriptor.c b/libusb/descriptor.c
index 74d6de5..0b0e314 100644
--- a/libusb/descriptor.c
+++ b/libusb/descriptor.c
@@ -1174,7 +1174,7 @@ int API_EXPORTED libusb_get_string_descriptor_ascii(libusb_device_handle *dev_ha
 		return LIBUSB_ERROR_IO;
 
 	if (tbuf[0] > r)
-		return LIBUSB_ERROR_IO;
+		tbuf[0] = r;
 
 	di = 0;
 	for (si = 2; si < tbuf[0]; si += 2) {
-- 
2.17.0

python-chai-drop-python2.patch
AgeCommit message (Expand)Author
2021-08-28gnu: python-chai: Remove Python2 code....* gnu/packages/patches/python-chai-drop-python2.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/python-xyz.scm (python-chai)[source]: Use it. Guillaume Le Vaillant