aboutsummaryrefslogtreecommitdiff
Initialize the context in 'test_auth_clear'.
Fixes the test suite on mips64el.

Patch by Mark H Weaver <mhw@netris.org>

--- libotr-4.1.1/tests/unit/test_auth.c.orig	2015-12-25 12:39:45.000000000 -0500
+++ libotr-4.1.1/tests/unit/test_auth.c	2016-03-17 18:53:10.169999706 -0400
@@ -67,6 +67,7 @@
 	OtrlAuthInfo *auth = &ctx.auth;
 
 	/* API call. */
+	otrl_auth_new(&ctx);
 	otrl_auth_clear(auth);
 
 	ok(auth->authstate == OTRL_AUTHSTATE_NONE &&
es/search.scm?id=fe83f96235ad9fadb52142877ce990772bbcd34b'>gnu: swish-e: Add 'bash' input for 'wrap-program'....It is required for cross-compilation. * gnu/packages/search.scm (swish-e)[inputs]: Add 'bash-minimal'. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: Iff70ecd244e2ca89c28015e2685e5966c08cf0d7 Maxime Devos 2024-08-28gnu: ugrep: Update to 6.5.0....* gnu/packages/search.scm (ugrep): Update to 6.5.0. Change-Id: Icfbd8874b7c668cae4c761ec21530ff1e3a0e041 Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> Ashish SHUKLA 2024-08-09gnu: ugrep: Update to 6.4.1....* gnu/packages/search (ugrep): Update to 6.4.1. Change-Id: I2b16899aa77518f0575b71ff57342ad3d91e67d4 Signed-off-by: jgart <jgart@dismail.de> Ashish SHUKLA 2024-08-07gnu: ugrep: Update to 6.4.0....* gnu/packages/search.scm (ugrep): Update to 6.4.0. Change-Id: I8a58b4f4b084cd254cd2e09ca81a5c2c980cadd1 Signed-off-by: jgart <jgart@dismail.de> Ashish SHUKLA 2024-08-01gnu: ugrep: Update to 6.3.0....* gnu/packages/search.scm (ugrep): Update to 6.3.0. [source]: Don't delete linux binaries, they're no longer included. [inputs]: Add dependency on brotli for brotli support. Change-Id: If1dc15b5f554079a5bc084501683bd6c5b5926d2 Signed-off-by: Christopher Baines <mail@cbaines.net> Ashish SHUKLA 2024-06-06gnu: ugrep: Update to 6.1.0....* gnu/packages/search.scm (ugrep): Update to 6.1.0. [source]: Delete included linux binaries. Change-Id: I13aa90578d8f618a0a9c2c67c59c41e8e219660f Signed-off-by: Christopher Baines <mail@cbaines.net> Ashish SHUKLA 2024-05-27gnu: ugrep: Update to 6.0.0....* gnu/packages/search.scm (ugrep): Update to 6.0.0. [source]: Adjust snippet to avoid deleting ug+ and ugrep+ shell scripts. Change-Id: I9beb1415fe8bfbe12a1e9d22d1606b1fc92ef16b Signed-off-by: 宋文武 <iyzsong@member.fsf.org> kiasoc5