aboutsummaryrefslogtreecommitdiff
Avoid a type mismatch that shows up in C++11.
Taken from <https://bugs.debian.org/853560>.

--- a/src/rtphint.cpp	2012-05-20 16:11:53.000000000 -0600
+++ b/src/rtphint.cpp	2017-05-16 10:25:26.930705191 -0600
@@ -339,7 +339,7 @@
                 pSlash = strchr(pSlash, '/');
                 if (pSlash != NULL) {
                     pSlash++;
-                    if (pSlash != '\0') {
+                    if (*pSlash != '\0') {
                         length = (uint32_t)strlen(pRtpMap) - (pSlash - pRtpMap);
                         *ppEncodingParams = (char *)MP4Calloc(length + 1);
                         strncpy(*ppEncodingParams, pSlash, length);
Marius Bakke 2020-08-28gnu: pluma: Update to 1.24.1....* gnu/packages/mate.scm (pluma): Update to 1.24.1. Tobias Geerinckx-Rice 2020-08-26gnu: mate-system-monitor: Update to 1.24.1....* gnu/packages/mate.scm (mate-system-monitor): Update to 1.24.1. [source]: Hard-code NAME. Tobias Geerinckx-Rice 2020-08-26gnu: mate-screensaver: Update to 1.24.1....* gnu/packages/mate.scm (mate-screensaver): Update to 1.24.1. [source]: Hard-code NAME. Tobias Geerinckx-Rice 2020-08-20gnu: mate-power-manager: Update to 1.24.2....* gnu/packages/mate.scm (mate-power-manager): Update to 1.24.2. [source]: Hard-code NAME. Tobias Geerinckx-Rice 2020-08-19gnu: engrampa: Update to 1.24.1....* gnu/packages/mate.scm (engrampa): Update to 1.24.1. [source]: Hard-code NAME. Tobias Geerinckx-Rice 2020-08-19gnu: eom: Update to 1.24.1....* gnu/packages/mate.scm (eom): Update to 1.24.1. [source]: Hard-code NAME. Tobias Geerinckx-Rice 2020-08-19gnu: mate-calc: Update to 1.24.1....* gnu/packages/mate.scm (mate-calc): Update to 1.24.1. [source]: Hard-code NAME. Tobias Geerinckx-Rice 2020-08-19gnu: mate-control-center: Update to 1.24.1....* gnu/packages/mate.scm (mate-control-center): Update to 1.24.1. [source]: Hard-code NAME. Tobias Geerinckx-Rice 2020-08-19gnu: caja-extensions: Update to 1.24.1....* gnu/packages/mate.scm (caja-extensions): Update to 1.24.1. [source]: Hard-code NAME. Tobias Geerinckx-Rice 2020-08-19gnu: mate-media: Update to 1.24.1....* gnu/packages/mate.scm (mate-media): Update to 1.24.1. [source]: Hard-code NAME. Tobias Geerinckx-Rice 2020-08-19gnu: mate-applets: Update to 1.24.1....* gnu/packages/mate.scm (mate-applets): Update to 1.24.1. [source]: Hard-code NAME. Tobias Geerinckx-Rice 2020-08-19gnu: mate-menus: Update to 1.24.1....* gnu/packages/mate.scm (mate-menus): Update to 1.24.1. [source]: Hard-code NAME. Tobias Geerinckx-Rice 2020-08-19gnu: libmatekbd: Update to 1.24.1....* gnu/packages/mate.scm (libmatekbd): Update to 1.24.1. [source]: Hard-code NAME. Tobias Geerinckx-Rice 2020-08-19gnu: libmatemixer: Update to 1.24.1....* gnu/packages/mate.scm (libmatemixer): Update to 1.24.1. [source]: Hard-code NAME. Tobias Geerinckx-Rice 2020-08-19gnu: mate-settings-daemon: Update to 1.24.1....* gnu/packages/mate.scm (mate-settings-daemon): Update to 1.24.1. [source]: Hard-code NAME. Tobias Geerinckx-Rice 2020-08-19gnu: mate-session-manager: Update to 1.24.1....* gnu/packages/mate.scm (mate-session-manager): Update to 1.24.1. [source]: Hard-code NAME. Tobias Geerinckx-Rice 2020-08-19gnu: mate-terminal: Update to 1.24.1....* gnu/packages/mate.scm (mate-terminal): Update to 1.24.1. Tobias Geerinckx-Rice 2020-08-19gnu: libmateweather: Update to 1.24.1....* gnu/packages/mate.scm (libmateweather): Update to 1.24.1. [source]: Hard-code NAME. Remove obsolete snippet. Tobias Geerinckx-Rice 2020-08-19gnu: mate-desktop: Update to 1.24.1....* gnu/packages/mate.scm (mate-desktop): Update to 1.24.1. [source]: Hard-code NAME. Tobias Geerinckx-Rice 2020-08-11gnu: mate-panel: Update to 1.24.1....* gnu/packages/mate.scm (mate-panel): Update to 1.24.1. Tobias Geerinckx-Rice 2020-08-11gnu: marco: Update to 1.24.1....* gnu/packages/mate.scm (marco): Update to 1.24.1. Tobias Geerinckx-Rice