aboutsummaryrefslogtreecommitdiff
Avoid a type mismatch that shows up in C++11.
Taken from <https://bugs.debian.org/853560>.

--- a/src/rtphint.cpp	2012-05-20 16:11:53.000000000 -0600
+++ b/src/rtphint.cpp	2017-05-16 10:25:26.930705191 -0600
@@ -339,7 +339,7 @@
                 pSlash = strchr(pSlash, '/');
                 if (pSlash != NULL) {
                     pSlash++;
-                    if (pSlash != '\0') {
+                    if (*pSlash != '\0') {
                         length = (uint32_t)strlen(pRtpMap) - (pSlash - pRtpMap);
                         *ppEncodingParams = (char *)MP4Calloc(length + 1);
                         strncpy(*ppEncodingParams, pSlash, length);