aboutsummaryrefslogtreecommitdiff
Copied from Debian.

From: Dave Martin
Subject: "rsc" doesnt exist anymore in thumb2

diff --git a/fixed.h b/fixed.h
index 4b58abf..ba4bc26 100644
--- a/fixed.h
+++ b/fixed.h
@@ -275,12 +275,25 @@ mad_fixed_t mad_f_mul_inline(mad_fixed_t x, mad_fixed_t y)
 	 : "+r" (lo), "+r" (hi)  \
 	 : "%r" (x), "r" (y))
 
+#ifdef __thumb__
+/* In Thumb-2, the RSB-immediate instruction is only allowed with a zero
+	operand.  If needed this code can also support Thumb-1 
+	(simply append "s" to the end of the second two instructions). */
+#  define MAD_F_MLN(hi, lo)  \
+    asm ("rsbs        %0, %0, #0\n\t"  \
+	 "sbc   %1, %1, %1\n\t"  \
+	 "sub   %1, %1, %2"  \
+	 : "+&r" (lo), "=&r" (hi)  \
+	 : "r" (hi)  \
+	 : "cc")
+#else /* ! __thumb__ */
 #  define MAD_F_MLN(hi, lo)  \
     asm ("rsbs	%0, %2, #0\n\t"  \
 	 "rsc	%1, %3, #0"  \
-	 : "=r" (lo), "=r" (hi)  \
+	 : "=&r" (lo), "=r" (hi)  \
 	 : "0" (lo), "1" (hi)  \
 	 : "cc")
+#endif /* __thumb__ */
 
 #  define mad_f_scale64(hi, lo)  \
     ({ mad_fixed_t __result;  \
d class='ctrl'>
authorPierre Neidhardt <ambrevar@gmail.com>2018-06-01 09:53:23 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-08 17:04:24 +0200
commitdaa9e89d564facecdde2ac68e3d4d6bb751ed7f1 (patch)
tree78d08fd4943577cdaa44f0e2f38fbb70c0b66de9 /gnu/packages/enlightenment.scm
parent49fd0392173f79c19dd85130d22fbec60a9bfe72 (diff)
downloadguix-daa9e89d564facecdde2ac68e3d4d6bb751ed7f1.tar.gz
guix-daa9e89d564facecdde2ac68e3d4d6bb751ed7f1.zip
gnu: Add emacs-helm-flycheck.
* gnu/packages/emacs.scm (emacs-helm-flycheck): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/enlightenment.scm')
0 files changed, 0 insertions, 0 deletions