aboutsummaryrefslogtreecommitdiff
The Clar test framework has a bug whereby it skips the parsing phase
on files with mtime=0.

Reported upstream at <https://github.com/vmg/clar/pull/78>.

diff --git a/tests/generate.py b/tests/generate.py
index b639c8f..111ca41 100644
--- a/tests/generate.py
+++ b/tests/generate.py
@@ -63,3 +63,3 @@ class Module(object):
 
-        self.mtime = 0
+        self.mtime = None # Guix sets all file mtimes to '0'
         self.enabled = True
'/guix/commit/gnu/tests?id=045ebb3e58d74c75f39ce47380045d3cd00359c3'>gnu: bootloader: Deprecate "device" field in favor of "target"....Andy Wingo 2017-08-23tests: Add 'libvirt-service-type' test....Christopher Baines 2017-08-21Merge branch 'master' into core-updatesMarius Bakke 2017-08-15gnu: Fix memcached service startup....Christopher Baines 2017-08-15Merge branch 'master' into core-updatesMark H Weaver 2017-08-13gnu: Add mpd service....Peter Mikkelsen 2017-08-01Merge branch 'master' into core-updatesMarius Bakke 2017-07-30services: Add memcached....Christopher Baines 2017-07-29gnu: services: admin: Add tailon....Christopher Baines 2017-07-23Merge branch 'master' into core-updatesLeo Famulari 2017-07-20tests: Use 'virtual-machine' records instead of monadic procedures....Ludovic Courtès 2017-07-18tests: ssh: Use 'guile-ssh'....Ludovic Courtès 2017-07-15gnu: Rename (gnu packages qemu) to (gnu packages virtualization)....宋文武 2017-06-21tests: Add extlinux gpt test....Mathieu Othacehe 2017-06-12marionette: Factorize 'wait-for-file'....Ludovic Courtès 2017-05-30activation: Change permissions on /root to #o700....Ludovic Courtès 2017-05-22Merge branch 'version-0.13.0'Marius Bakke 2017-05-21tests: ssh: Use 'guile2.0-ssh'....Ludovic Courtès 2017-05-20services: user-homes: Do not create home directories marked as no-create....Ludovic Courtès 2017-05-18services: user-homes: Do not create home directories marked as no-create....Ludovic Courtès 2017-05-16bootloader: Add extlinux support....Mathieu Othacehe 2017-05-13tests: "basic" test loads (guix …) modules from the right place....Ludovic Courtès 2017-05-13tests: Strengthen GC root test....Ludovic Courtès 2017-04-19tests: mail: Add test for exim...Carlo Zancanaro 2017-04-16tests: dicod: Bail out if we cannot connect within 20 seconds....Ludovic Courtès 2017-04-16services: 'service-parameters' becomes 'service-value'....Ludovic Courtès 2017-04-15tests: Remove unused import (gnu system grub)....Danny Milosavljevic 2017-04-01tests: Add GNU dicod test....Ludovic Courtès 2017-04-01tests: Introduce 'simple-operating-system' and use it....Ludovic Courtès