aboutsummaryrefslogtreecommitdiff
# We insert a hook called "@SOUND_THEME_DIRECTORY@" where, at build time, we
# insert the directory of the package "sound-theme-freedesktop" in the store.

--- src/sound-theme-spec.c.orig	2015-01-11 13:13:29.520527358 +0100
+++ src/sound-theme-spec.c	2015-01-11 14:27:23.035046849 +0100
@@ -321,9 +321,13 @@
         const char *g;
 
         if (!(g = getenv("XDG_DATA_DIRS")) || *g == 0)
-                return "/usr/local/share:/usr/share";
-
-        return g;
+                return "@SOUND_THEME_DIRECTORY@";
+        else {
+                const char *stp = ":@SOUND_THEME_DIRECTORY@";
+                size_t len = strlen(stp) + strlen(g) + 1;
+                char *g2 = (char*) malloc(len);
+                return strcat(strcpy(g2, g), stp);
+        }
 }
 
 static int load_theme_dir(ca_theme_data *t, const char *name) {
1f'>gnu: GnuPG: Really use ~/.guix-profile/bin/pinentry by default....Fixes <https://bugs.gnu.org/24076>. * gnu/packages/patches/gnupg-default-pinentry.patch: New file. Use $HOME to find the user's Guix profile and installed pinentry. * gnu/local.mk (dist_patch_DATA): Add the patch. * gnu/packages/gnupg.scm (gnupg)[source]: Use it. Leo Famulari 2020-03-28Revert "gnu: gnupg: Use ~/.guix-profile/bin/pinentry by default."...This commit didn't work: https://issues.guix.gnu.org/issue/24076#13 This reverts commit c7af9d0b5ebaa1fdb08ff5d8a56004998bcd8103. Leo Famulari 2020-03-26gnu: gnupg: Use ~/.guix-profile/bin/pinentry by default....Fixes <https://bugs.gnu.org/24076>. Reported by Danny Milosavljevic <dannym@scratchpost.org>. * gnu/packages/patches/gnupg-default-pinentry.patch: New file. * gnu/packages/gnupg.scm (gnupg)[source]: Use it. * gnu/local.mk (dist_patch_DATA): Add it. Ludovic Courtès