aboutsummaryrefslogtreecommitdiff
;;; GNU G
Use shared gtest instead of submodule

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 617e4b2..2857875 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,7 +18,6 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")
 include(GNUInstallDirs)
 
 project(leelaz)
-add_subdirectory(gtest EXCLUDE_FROM_ALL) # We don't want to install gtest, exclude it from `all`
 
 # Required Packages
 set(Boost_MIN_VERSION "1.58.0")
@@ -27,6 +26,7 @@ find_package(Boost 1.58.0 REQUIRED program_options filesystem)
 find_package(Threads REQUIRED)
 find_package(ZLIB REQUIRED)
 find_package(OpenCL REQUIRED)
+find_package(GTest REQUIRED)
 # We need OpenBLAS for now, because we make some specific
 # calls. Ideally we'd use OpenBLAS is possible and fall back to
 # not doing those calls if it's not present.
@@ -93,6 +93,7 @@ include_directories(${IncludePath})
 include_directories(${Boost_INCLUDE_DIRS})
 include_directories(${OpenCL_INCLUDE_DIRS})
 include_directories(${ZLIB_INCLUDE_DIRS})
+include_directories(${GTEST_INCLUDE_DIRS})
 
 if((UNIX AND NOT APPLE) OR WIN32)
     include_directories(${BLAS_INCLUDE_DIRS})
@@ -141,7 +142,8 @@ target_link_libraries(tests ${Boost_LIBRARIES})
 target_link_libraries(tests ${BLAS_LIBRARIES})
 target_link_libraries(tests ${OpenCL_LIBRARIES})
 target_link_libraries(tests ${ZLIB_LIBRARIES})
-target_link_libraries(tests gtest_main ${CMAKE_THREAD_LIBS_INIT})
+target_link_libraries(tests ${GTEST_BOTH_LIBRARIES})
+target_link_libraries(tests ${CMAKE_THREAD_LIBS_INIT})
 
 include(GetGitRevisionDescription)
 git_describe(VERSION --tags)
rm7pd5gvcrpf98zv40yy")))) (build-system python-build-system) (native-inputs (list python-pytest)) (home-page "https://github.com/benoit-pierre/plover_stroke") (synopsis "Stroke handling helper library for Plover") (description "This package provides a helper class for working with steno strokes.") (license license:gpl2+))) (define-public plover (package (name "plover") (version "4.0.0.dev12") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/openstenoproject/plover") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "0vk6nh2gpn7f7rv2spi2a7n3m0d9kaan6r22mx3vwxprpbvrkbm8")))) (build-system python-build-system) (arguments (list #:phases #~(modify-phases %standard-phases (replace 'check (lambda* (#:key tests? #:allow-other-keys) (when tests? (invoke "python" "-m" "pytest" "-p" "pytest-qt" "-p" "xvfb" "test" ;; FIXME: Ignore failing test. "--ignore" "test/gui_qt/test_dictionaries_widget.py")))) ;; Ensure that icons are found at runtime. (add-after 'install 'wrap-executable (lambda* (#:key inputs #:allow-other-keys) (wrap-program (string-append #$output "/bin/plover") `("QT_PLUGIN_PATH" prefix (,(search-input-directory inputs "/lib/qt5/plugins/"))) `("LD_LIBRARY_PATH" prefix (,(string-append #$(this-package-input "dbus") "/lib"))))))))) (native-inputs (list python-babel python-mock python-pytest python-pytest-qt python-pytest-xvfb)) (inputs (list bash-minimal dbus python-appdirs python-dbus python-hidapi python-plover-stroke python-pyqt python-pyserial python-rtf-tokenize python-wcwidth python-xlib qtsvg-5)) (home-page "https://www.openstenoproject.org/plover/") (synopsis "Stenography engine") (description "Plover (rhymes with @emph{lover}) is a desktop application that allows anyone to use stenography to write on their computer, up to speeds of 200WPM and beyond.") (license license:gpl2+)))