aboutsummaryrefslogtreecommitdiff
# Authhor: Damyan Ivanov <dmn@debian.org>
# Description: rename pipe2 symbol to pipe2_kbdl to avoid clashes with the one
#              declared in system unistd.h
# Debian-Bug: 527705
# Upstream-Report: http://www.freelists.org/post/olofsonprojects/kobodeluxe-failing-to-build-in-Debian-enemiesh75-error-const-enemy-kind-pipe2-redeclared-as-different-kind-of-symbol
--- a/enemies.h
+++ b/enemies.h
@@ -72,7 +72,7 @@ extern const enemy_kind bombdeto;
 extern const enemy_kind cannon;
 extern const enemy_kind pipe1;
 extern const enemy_kind core;
-extern const enemy_kind pipe2;
+extern const enemy_kind pipe2_kbdl;
 extern const enemy_kind rock;
 extern const enemy_kind ring;
 extern const enemy_kind enemy_m1;
@@ -430,7 +430,7 @@ inline int _enemy::realize()

 inline int _enemy::is_pipe()
 {
-	return ((_state != notuse) && ((ek == &pipe1) || (ek == &pipe2)));
+	return ((_state != notuse) && ((ek == &pipe1) || (ek == &pipe2_kbdl)));
 }


--- a/enemy.cpp
+++ b/enemy.cpp
@@ -755,10 +755,10 @@ void _enemy::move_core()

 void _enemy::kill_core()
 {
-	enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 3);
-	enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 7);
-	enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 1);
-	enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 5);
+	enemies.make(&pipe2_kbdl, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 3);
+	enemies.make(&pipe2_kbdl, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 7);
+	enemies.make(&pipe2_kbdl, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 1);
+	enemies.make(&pipe2_kbdl, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 5);
 	enemies.make(&explosion4, CS2PIXEL(x), CS2PIXEL(y));
 	sound.g_base_core_explo(x, y);
 	release();
@@ -978,19 +978,19 @@ void _enemy::move_pipe2()
 	}
 	p ^= a;
 	if(p & U_MASK)
-		enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 1);
+		enemies.make(&pipe2_kbdl, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 1);
 	if(p & R_MASK)
-		enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 3);
+		enemies.make(&pipe2_kbdl, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 3);
 	if(p & D_MASK)
-		enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 5);
+		enemies.make(&pipe2_kbdl, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 5);
 	if(p & L_MASK)
-		enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 7);
+		enemies.make(&pipe2_kbdl, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 7);
 	manage.add_score(10);
 	release();
 }


-const enemy_kind pipe2 = {
+const enemy_kind pipe2_kbdl = {
 	0,
 	&_enemy::make_pipe2,
 	&_enemy::move_pipe2,
:00:23 +0200'>2018-06-22gnu: corkscrew: Clean up dead code....Tobias Geerinckx-Rice 2018-06-22gnu: corkscrew: Deduplicate documentation directories....Tobias Geerinckx-Rice 2018-06-22gnu: corkscrew: Return #t from all phases....Tobias Geerinckx-Rice 2018-06-22gnu: guile-ssh: Return #t from all phases....Tobias Geerinckx-Rice 2018-05-28gnu: libssh2: Fix build on MIPS systems....Mark H Weaver 2018-05-06Merge branch 'master' into core-updatesMarius Bakke 2018-05-01gnu: liboop: Update to 1.0.1....Tobias Geerinckx-Rice 2018-04-30Merge branch 'master' into core-updatesMark H Weaver 2018-04-25gnu: guile-ssh: Move files from bin to examples directory....Roel Janssen 2018-04-10Merge branch 'master' into core-updatesMark H Weaver 2018-04-05gnu: openssh: Update to 7.7p1....Leo Famulari 2018-03-29Merge branch 'master' into core-updatesMarius Bakke 2018-03-25gnu: autossh: Update to 1.4f....Tobias Geerinckx-Rice 2018-03-23gnu: openssh: Use invoke....Mark H Weaver 2018-03-23gnu: libssh2: Use invoke....Mark H Weaver 2018-03-20Merge branch 'master' into core-updatesMark H Weaver 2018-03-20Correct name and Email for ng0....ng0 2018-03-16gnu: All snippets report errors using exceptions, else return #t....Mark H Weaver 2018-02-28gnu: dropbear: Update to 2018.76....Tobias Geerinckx-Rice 2018-02-06gnu: libssh: Update to commit 239d0f7 of branch 'v0-7'....Ludovic Courtès 2017-12-24gnu: pdsh: Update to 2.33....ng0