aboutsummaryrefslogtreecommitdiff
Search the "extra libs" in GUIX_KF5INIT_LIB_PATH (which basically is a
collection of all /lib directories). We can not hard-code the full path to the
libsKF5Plasam, since adding palse-workspace

Adopted from NixOS
pkgs/development/libraries/kde-frameworks/kinit/kdeinit-extra_libs.patch

===================================================================
--- kinit-5.32.0/src/kdeinit/kinit-5.32.0/src/kdeinit/.orig
+++ kinit-5.32.0/src/kdeinit/kinit.cpp
@@ -96,9 +96,9 @@
     "libKF5Parts.5.dylib",
     "libKF5Plasma.5.dylib"
 #else
-    "libKF5KIOCore.so.5",
-    "libKF5Parts.so.5",
-    "libKF5Plasma.so.5"
+    "GUIX_PKGS_KF5_KIO/lib/libKF5KIOCore.so.5",
+    "GUIX_PKGS_KF5_PARTS/lib/libKF5Parts.so.5",
+    "GUIX_PKGS_KF5_PLASMA/lib/libKF5Plasma.so.5"
 #endif
 };
 #endif
@@ -1673,7 +1673,7 @@
 #if defined(Q_OS_UNIX) && !defined(Q_OS_OSX)
     if (!d.suicide && qEnvironmentVariableIsEmpty("KDE_IS_PRELINKED")) {
         for (const char *extra_lib : extra_libs) {
-            const QString extra = findSharedLib(QString::fromLatin1(extra_lib));
+            const QString extra = QString::fromLatin1(extra_lib);
             if (!extra.isEmpty()) {
                 QLibrary l(extra);
                 l.setLoadHints(QLibrary::ExportExternalSymbolsHint);
-type' isn't necessarily present in OS, so we cannot use the 'modify-services' as it would now error out. This was happening with the "guix system docker-image" test in 'tests/guix-system.sh'. * gnu/system/linux-container.scm (containerized-operating-system): Use 'filter-map' instead of 'remove' + 'modify-services'. Ludovic Courtès 2023-03-26linux-container: Remove hosts-service-type when network is shared....Fixes <https://issues.guix.gnu.org/61627>. * gnu/system/linux-container.scm (container-essential-services): When shared-network? is true, remove the hosts-service-type service kind. Pierre Langlois 2022-12-01linux-container: Do not replace nscd-service-type....* gnu/system/linux-container.scm (containerized-operating-system): Respect customizations to the nscd-service-type and only modify the caches field. Ricardo Wurmus 2022-08-09linux-container: container-script: Parse command line options....* gnu/system/linux-container.scm (container-script): Accept command line options to bind mount host directories into the container. * doc/guix.texi (Invoking guix system): Document options. Ricardo Wurmus 2022-05-31gnu: Remove wicd....The last release is from 2017, stuck on Python 2. * gnu/packages/wicd.scm: Delete file. * gnu/packages/patches/wicd-bitrate-none-fix.patch: Delete file. * gnu/packages/patches/wicd-get-selected-profile-fix.patch: Likewise. * gnu/packages/patches/wicd-urwid-1.3.patch: Likewise. * gnu/packages/patches/wicd-wpa2-ttls.patch: Likewise. * gnu/local.mk: De-register them. * gnu/services/networking.scm: Remove wicd service... * doc/guix.texi: ... and its documentation. * gnu/system/linux-container.scm (containerized-operating-system) <services-to-drop>: Remove wicd-service-type. Maxim Cournoyer 2022-03-19linux-container: Add #:guest-uid and #:guest-gid to 'eval/container'....* gnu/system/linux-container.scm (eval/container): Add #:guest-uid and #:guest-gid and honor them. Ludovic Courtès 2022-03-19linux-container: 'eval/container' honors #:namespaces....* gnu/system/linux-container.scm (eval/container): Pass #:namespaces to 'call-with-container'. Ludovic Courtès