aboutsummaryrefslogtreecommitdiff
Downloaded from https://anonscm.debian.org/viewvc/pkg-games/packages/trunk/kiki-the-nano-bot/debian/patches/missing-includes.patch?revision=7984&view=co

Status: in upstream CVS

--- a/kodilib/src/handler/KPickable.h
+++ b/kodilib/src/handler/KPickable.h
@@ -8,6 +8,7 @@
 
 #include "KIntrospection.h"
 #include <vector>
+#include <limits.h>
 
 #define DEBUG_PICKING		false
 
--- a/kodilib/src/tools/KIntrospection.h
+++ b/kodilib/src/tools/KIntrospection.h
@@ -11,6 +11,7 @@
 #endif
 
 #include <string>
+#include <string.h>
 
 // --------------------------------------------------------------------------------------------------------
 class KClassInfo
--- a/kodilib/src/tools/KStringTools.cpp
+++ b/kodilib/src/tools/KStringTools.cpp
@@ -6,7 +6,7 @@
 #include "KStringTools.h"
 #include "KVector.h"
 
-#include <sys/types.h> 	// INT_MAX
+#include <limits.h> // INT_MAX
 #include <stdio.h>
 
 // --------------------------------------------------------------------------------------------------------
--- a/kodilib/src/tools/KStringTools.h
+++ b/kodilib/src/tools/KStringTools.h
@@ -9,6 +9,7 @@
 #include <string>
 #include <vector>
 #include <stdarg.h>
+#include <string.h>
 
 // --------------------------------------------------------------------------------------------------------
 
--- a/kodilib/src/tools/KXMLTools.cpp
+++ b/kodilib/src/tools/KXMLTools.cpp
@@ -7,6 +7,7 @@
 #include "KConsole.h"
 #include "KSeparatedMatrix.h"
 #include <stdio.h>
+#include <stdlib.h>
 
 // --------------------------------------------------------------------------------------------------------
 std::string kXMLTag ( const std::string & name, const std::string & attributes, int depth )