aboutsummaryrefslogtreecommitdiff
Fix one of upstream non-determinism, tracked here:

https://github.com/JuliaLang/julia/issues/34115
https://github.com/JuliaLang/julia/issues/25900


Patch by Nicoló Balzarotti <nicolo@nixo.xyz>.

--- a/base/loading.jl
+++ b/base/loading.jl
@@ -1131,7 +1131,10 @@ function _include_dependency(mod::Module, _path::AbstractString)
     end
     if _track_dependencies[]
         @lock require_lock begin
-        push!(_require_dependencies, (mod, path, mtime(path)))
+          push!(_require_dependencies,
+                (mod, path,
+                 haskey(ENV, "SOURCE_DATE_EPOCH") ?
+                 parse(Float64, ENV["SOURCE_DATE_EPOCH"]) : mtime(path)))
         end
     end
     return path, prev
 end