aboutsummaryrefslogtreecommitdiff
From d80cfc83325f8e95d35ecd9f15b36b96fa9ed3ee Mon Sep 17 00:00:00 2001
From: Simon South <simon@simonsouth.net>
Date: Sat, 6 Jun 2020 18:56:56 -0400
Subject: [PATCH] Disable branch-patching

This patch disables JamVM's branch-patching optimization, which tends
to make JamVM fail with an "Illegal instruction" error on x86_64 (and
possibly other architectures that use variable-length instructions)
when built using modern versions of gcc and glibc.
---
 src/init.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/src/init.c b/src/init.c
index 32539cf..38ad54b 100644
--- a/src/init.c
+++ b/src/init.c
@@ -72,8 +72,8 @@ void setDefaultInitArgs(InitArgs *args) {
 #ifdef INLINING
     args->replication_threshold = 10;
     args->profile_threshold     = 10;
-    args->branch_patching_dup   = TRUE;
-    args->branch_patching       = TRUE;
+    args->branch_patching_dup   = FALSE;
+    args->branch_patching       = FALSE;
     args->print_codestats       = FALSE;
     args->join_blocks           = TRUE;
     args->profiling             = TRUE;
-- 
2.25.2

2021-04-05gnu: libffi: Add 'release-monitoring-url'....* gnu/packages/libffi.scm (libffi)[home-page]: Change to sourceware.org. [properties]: New field. Ludovic Courtès 2021-03-15gnu: libffi: Inline all patches....* gnu/packages/libffi.scm (libffi)[source]: Add patch. [arguments]: Remove custom patch phases. [inputs]: Remove field. Efraim Flashner 2021-02-01gnu: python-cffi: Do not set PYTHONPATH....* gnu/packages/libffi.scm (python-cffi): Remove trailing #t. [phases]{check}: Do not set PYTHONPATH. Maxim Cournoyer 2021-01-13Merge branch 'staging' into 'core-updates'....Conflicts: gnu/local.mk gnu/packages/cmake.scm gnu/packages/curl.scm gnu/packages/gl.scm gnu/packages/glib.scm gnu/packages/guile.scm gnu/packages/node.scm gnu/packages/openldap.scm gnu/packages/package-management.scm gnu/packages/python-xyz.scm gnu/packages/python.scm gnu/packages/tls.scm gnu/packages/vpn.scm gnu/packages/xorg.scm Maxim Cournoyer 2020-12-29Merge branch 'ungrafting' into stagingMarius Bakke 2020-12-27gnu: libffi: On powerpc, patch with --force....As explained in bug 45252, this is the right way to invoke it. Efraim has confirmed that it is OK to make this change on master branch for the generic powerpc case, even though it will in theory cause rebuilds on that architecture, since in practice it isn't actually being used yet. * gnu/packages/libffi.scm (arguments): Change the invocation of the "patch" tool in the case where the %current-target-system or %current-system begins with "powerpc", so that we invoke it using --force instead of --batch. Chris Marusich 2020-12-27gnu: libffi: On powerpc64le, patch using --force....As explained in bug 45252, this is the right way to invoke it. * gnu/packages/libffi.scm (arguments): Change the invocation of the "patch" tool in the case where the %current-target-system or %current-system begins with "powerpc64le", so that we invoke it using --force instead of --batch. Chris Marusich 2020-12-21Merge branch 'ungrafting' into stagingMarius Bakke 2020-12-20Revert "gnu: libffi: Add unreleased patch to fix float128 on powerpc64le."...This reverts commit 4fff5ab24126a152b50c036b9bf8dc6f2740f094. In <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=45252> we decided to apply a patch to master instead, so this change is no longer needed on core-updates. Chris Marusich 2020-12-20gnu: libffi: Add unreleased patch to fix float128 on powerpc64le....Fixes <https://bugs.gnu.org/45252>. * gnu/packages/patches/libffi-float128-powerpc64le.patch: Import patch file from <https://github.com/libffi/libffi/pull/561.patch>. * gnu/packages/libffi.scm (libffi)[arguments]: Apply patch conditionally for powerpc64le-* systems in a phase. [inputs]: Add patch as input conditionally for powerpc64le-* systems. * gnu/local.mk (dist_patch_DATA): Add patch file to build system. Signed-off-by: Chris Marusich <cmmarusich@gmail.com> John Doe 2020-12-13gnu: python-cffi: Update to 1.14.4....* gnu/packages/libffi.scm (python-cffi): Update to 1.14.4. Marius Bakke 2020-11-29Merge remote-tracking branch 'origin/master' into core-updatesChristopher Baines 2020-11-28gnu: libffi: Add unreleased patch to fix float128 on powerpc64le....* gnu/packages/patches/libffi-float128-powerpc64le.patch: Import patch file from <https://github.com/libffi/libffi/pull/561.patch>. * gnu/packages/libffi.scm (libffi)[patches]: Apply patch. * gnu/local.mk (dist_patch_DATA): Add patch file to build system. Signed-off-by: Ludovic Courtès <ludo@gnu.org> John Doe 2020-11-07gnu: libffi: Fix building on powerpc....* gnu/packages/libffi.scm (libffi)[inputs]: New field. [arguments]: Add 'apply-patch' phase when targeting PowerPC. * gnu/packages/patches/libffi-3.3-powerpc-fixes.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Co-authored-by: Ludovic Courtès <ludo@gnu.org> Efraim Flashner