Skip a GC test known to be flaky:
https://issues.guix.gnu.org/issue/37425
https://github.com/golang/go/issues/27636
--- go/src/runtime/gc_test.go 2019-09-16 23:10:18.200680387 +0200
+++ go/src/runtime/gc_test.go 2019-09-16 23:11:50.324360646 +0200
@@ -27,6 +27,9 @@ func TestGcSys(t *testing.T) {
if runtime.GOOS == "linux" && runtime.GOARCH == "arm64" {
t.Skip("skipping test; GOOS=linux GOARCH=arm64 https://github.com/golang/go/issues/27636")
}
+ if runtime.GOOS == "linux" {
+ t.Skip("skipping test; GOOS=linux https://issues.guix.gnu.org/issue/37425")
+ }
got := runTestProg(t, "testprog", "GCSys")
want := "OK\n"
if got != want {
3b1c2b1006ebeede016cca578d5f571fc7a8'/>
Avoid "multiple definition of `mystruct'" error from `ld`:
Submitted upstream at https://github.com/idris-lang/Idris-dev/issues/4914
--- a/test/ffi008/ffi008.h 1969-12-31 18:00:01.000000000 -0600
+++ a/test/ffi008/ffi008.h 2022-04-13 00:32:35.561262598 -0500
@@ -10,7 +10,7 @@
int16_t b;
};
-struct test2 mystruct;
+extern struct test2 mystruct;
int size1(void);
int size2(void);
--- a/test/ffi008/ffi008.c 1969-12-31 18:00:01.000000000 -0600
+++ a/test/ffi008/ffi008.c 2022-04-13 00:32:53.145186302 -0500
@@ -11,6 +11,8 @@
return sizeof(struct test2);
}
+struct test2 mystruct;
+
void print_mystruct(void) {
printf("a: %d b: %d\n", mystruct.a, mystruct.b);
}