aboutsummaryrefslogtreecommitdiff
From 919dd016be1abd213b3a7d0e9a3b79e3286ef6ad Mon Sep 17 00:00:00 2001
From: Simon South <simon@simonsouth.net>
Date: Wed, 10 Jun 2020 13:02:09 -0400
Subject: [PATCH] aarch64: Use only C++98

This patch removes an unneeded C++ template that causes the build to
fail for aarch64 using gcc 7.5.0 and its default support for only the
C++98 standard.

It is based on original work by Severin Gehwolf <sgehwolf@redhat.com>.
See: https://bugzilla.redhat.com/show_bug.cgi?id=1307224
---
 src/cpu/aarch64/vm/sharedRuntime_aarch64.cpp | 4 ----
 1 file changed, 4 deletions(-)

diff --git a/src/cpu/aarch64/vm/sharedRuntime_aarch64.cpp b/src/cpu/aarch64/vm/sharedRuntime_aarch64.cpp
index 0bc0a2b..6f73ca0 100644
--- a/src/cpu/aarch64/vm/sharedRuntime_aarch64.cpp
+++ b/src/cpu/aarch64/vm/sharedRuntime_aarch64.cpp
@@ -194,10 +194,6 @@ static int reg2offset_out(VMReg r) {
   return (r->reg2stack() + SharedRuntime::out_preserve_stack_slots()) * VMRegImpl::stack_slot_size;
 }
 
-template <class T> static const T& min (const T& a, const T& b) {
-  return (a > b) ? b : a;
-}
-
 // ---------------------------------------------------------------------------
 // Read the array of BasicTypes from a signature, and compute where the
 // arguments should go.  Values in the VMRegPair regs array refer to 4-byte
-- 
2.26.2

ltip'>* gnu/packages/jemalloc.scm (jemalloc): Update to 5.1.0. [source](patches): Remove. * gnu/packages/patches/jemalloc-arm-address-bits.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Marius Bakke 2017-12-10gnu: jemalloc: Fix tests for aarch64....* gnu/packages/patches/jemalloc-arm-address-bits.patch: New patch. * gnu/packages/jemalloc.scm (jemalloc)[source]: Use it. * gnu/local.mk (dist_patch_DATA): Add it. Eric Bavier 2017-12-11gnu: rust: Update rust to 1.22.1 and cargo to 1.23.0....* gnu/packages/rust.scm (%rust-bootstrap-binaries-version): Update version. (%rust-bootstrap-binaries): Use x86_64 rust bootstrap package for x86_64 build. (%cargo-reference-project-file): Use specific file as "project" file when patching rust vendored sources. (%cargo-reference-hash): sha256 sum for %cargo-reference-project-file. (rustc-bootstrap): Use bootstrap package with host architecture. (cargo-bootstrap): Use bootstrap package with host architecture. (rustc): Add new test dependency, fix build issues, use "./x.py" script for build instead of "./configure". (cargo): Update dependencies, patch shebangs for vendored sources * gnu/packages/jemalloc.scm: Add jemalloc-4.5.0 release. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org> Nikolai Merinov 2017-08-28gnu: jemalloc: Update to 5.0.1....* gnu/packages/jemalloc.scm (jemalloc): Update to 5.0.1. [inputs]: Add perl. Efraim Flashner 2017-04-30gnu: jemalloc: Disable transparent huge pages on non-Intel systems....* gnu/packages/jemalloc.scm (jemalloc)[arguments]: On non-Intel systems add '--disable-thp' to #:configure-flags. Adjust #:phases to remove offending test which incorrectly tests transparent huge pages. Efraim Flashner 2017-03-01gnu: jemalloc: Update to 4.5.0....* gnu/packages/jemalloc.scm (jemalloc): Update to 4.5.0. Marius Bakke 2017-02-19gnu: jemalloc: Update to 4.4.0....* gnu/packages/jemalloc.scm (jemalloc): Update to 4.4.0. [source, home-page]: Update to current URLs. Marius Bakke