aboutsummaryrefslogtreecommitdiff
Remove references to bundled mbedtls library to use the one from inputs.

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1e27d21..f0eb1a5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -85,13 +85,6 @@ endif()
 
 set(USE_STATIC_MBEDTLS_LIBRARY ON)
 set(USE_SHARED_MBEDTLS_LIBRARY OFF)
-add_subdirectory("lib/mbedtls" EXCLUDE_FROM_ALL)
-
-# Compile the mbedtls library as a static with position independent code,
-# because we need it for both a shared and static library
-set_property(TARGET mbedtls PROPERTY POSITION_INDEPENDENT_CODE ON)
-set_property(TARGET mbedcrypto PROPERTY POSITION_INDEPENDENT_CODE ON)
-set_property(TARGET mbedx509 PROPERTY POSITION_INDEPENDENT_CODE ON)
 
 add_subdirectory(src)
 
ass='ctrl'>space:mode:
authorLudovic Courtès <ludo@gnu.org>2016-11-09 16:27:29 +0100
committerLudovic Courtès <ludo@gnu.org>2016-11-09 21:24:44 +0100
commitc169d91e5a0be92b6bd48a8fd98c43078d2a12ef (patch)
tree36378c2cf980be7a15294644908636c9ebc52c0a /gnu/packages/patches/hdf-eos2-build-shared.patch
parent8bb115e0c6673143f174e88df43594077979945b (diff)
downloadguix-c169d91e5a0be92b6bd48a8fd98c43078d2a12ef.tar.gz
guix-c169d91e5a0be92b6bd48a8fd98c43078d2a12ef.zip
lint: 'cve' checker catches 'tls-certificate-error'.
Reported by Frederick Muriithi <fredmanglis@gmail.com>. * guix/scripts/lint.scm (tls-certificate-error-string): New procedure. (validate-uri): Use it. (current-vulnerabilities*): Catch 'tls-certificate-error' and print a warning.
Diffstat (limited to 'gnu/packages/patches/hdf-eos2-build-shared.patch')
0 files changed, 0 insertions, 0 deletions