aboutsummaryrefslogtreecommitdiff
Traverse the entities hash's keys in sorted order to ensure reproducibility.

--- libhubbub-0.3.3/build/make-entities.pl
+++ libhubbub-0.3.3/build/make-entities.pl
@@ -86,7 +86,7 @@
 
 my $trie;
 
-foreach my $key (keys %entities) {
+foreach my $key (sort keys %entities) {
    $trie = insert_node($trie, $key, $entities{$key});
 }
 
>Author 2018-12-14deduplication: Gracefully handle ENOSPC raised by 'link' calls....Ludovic Courtès 2018-09-04Switch to Guile-Gcrypt....Ludovic Courtès 2018-07-03deduplication: Place link files under /gnu/store/.links....Ludovic Courtès 2018-06-14deduplicate: Fix a couple of thinkos....Ludovic Courtès 2018-06-01Add (guix store deduplication)....Caleb Ristvedt