aboutsummaryrefslogtreecommitdiff
Don't build/install/use bundled gctp code/headers.

* cproj.h, proj.h: part of GCTP, therefore already present.
* HE5_config.h, tutils.h: used for library building and testing.

diff --git a/Makefile.in b/Makefile.in
index f160d0d..367b537 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -206,7 +206,7 @@ LIBGCTP = $(top_builddir)/gctp/src/libGctp.la
 @TESTDRIVERS_CONDITIONAL_TRUE@TESTDRIVERS = testdrivers
 @INSTALL_INCLUDE_CONDITIONAL_FALSE@INCLUDE = 
 @INSTALL_INCLUDE_CONDITIONAL_TRUE@INCLUDE = include
-SUBDIRS = gctp src $(INCLUDE) samples $(TESTDRIVERS)
+SUBDIRS = src $(INCLUDE) samples $(TESTDRIVERS)
 all: all-recursive
 
 .SUFFIXES:
diff --git a/samples/Makefile.in b/samples/Makefile.in
index 59331dd..64fda89 100644
--- a/samples/Makefile.in
+++ b/samples/Makefile.in
@@ -206,7 +206,6 @@ he5_gd_datainfo_SOURCES = he5_gd_datainfo.c
 he5_gd_datainfo_OBJECTS = he5_gd_datainfo.$(OBJEXT)
 he5_gd_datainfo_LDADD = $(LDADD)
 am__DEPENDENCIES_1 = $(top_builddir)/src/libhe5_hdfeos.la
-am__DEPENDENCIES_2 = $(top_builddir)/gctp/src/libGctp.la
 he5_gd_datainfo_DEPENDENCIES = $(am__DEPENDENCIES_1) \
 	$(am__DEPENDENCIES_2)
 he5_gd_defexternalfld_SOURCES = he5_gd_defexternalfld.c
@@ -1093,7 +1092,7 @@ sharedstatedir = @sharedstatedir@
 sysconfdir = @sysconfdir@
 target_alias = @target_alias@
 LIBHDFEOS5 = $(top_builddir)/src/libhe5_hdfeos.la
-LIBGCTP = $(top_builddir)/gctp/src/libGctp.la
+LIBGCTP =
 
 # Boilerplate definitions file
 
diff --git a/include/Makefile.in b/include/Makefile.in
index a572128..64dabb5 100644
--- a/include/Makefile.in
+++ b/include/Makefile.in
@@ -190,8 +190,7 @@ LIBGCTP = $(top_builddir)/gctp/src/libGctp.la
 # Boilerplate include
 
 # Headers to install
-include_HEADERS = HE5_GctpFunc.h HE5_HdfEosDef.h HE5_config.h cproj.h ease.h \
-                  isin.h proj.h tutils.h cfortHdf.h
+include_HEADERS = HE5_GctpFunc.h HE5_HdfEosDef.h ease.h isin.h cfortHdf.h
 
 all: HE5_config.h
 	$(MAKE) $(AM_MAKEFLAGS) all-am
-- 
2.10.0
51ed530204f52a83cbc846ae2411b229fbbf6b93'>gnu: node@10: Build with 'libuv-for-node'....* gnu/packages/node.scm (node)[inputs, native-inputs]: Change from LIBUV to LIBUV-FOR-NODE. Marius Bakke 2022-08-30Merge branch 'staging' into core-updatesMarius Bakke 2022-08-30gnu: Introduce versioned 'openssl-1.1' variable.......and use it in packages that do not yet support 3.0. * gnu/packages/tls.scm (openssl): Rename to ... (openssl-1.1): ... this. (openssl/fixed): Inherit from OPENSSL-1.1. (openssl-3.0): Likewise. (openssl): Turn into alias for OPENSSL-1.1. * gnu/packages/ruby.scm (ruby-2.6)[inputs]: Change from OPENSSL to OPENSSL-1.1. (ruby-3.0)[inputs]: Change "openssl" input to OPENSSL. (ruby-3.1): Inherit from RUBY-3.0. * gnu/packages/python.scm (python-2.7)[inputs]: Change from OPENSSL to OPENSSL-1.1. (python-3.9)[inputs]: Replace "openssl" with OPENSSL. * gnu/packages/python-crypto.scm (python-cryptography)[inputs]: Change from OPENSSL to OPENSSL-1.1. * gnu/packages/databases.scm (mariadb)[inputs]: Likewise. * gnu/packages/node.scm (node)[native-inputs, inputs]: Likewise. (node-lts)[native-inputs]: Likewise. Marius Bakke 2022-08-11Merge branch 'staging' into core-updatesMarius Bakke 2022-08-02gnu: node-lts: Build with icu4c-71....* gnu/packages/node.scm (node-lts)[inputs]: Replace icu4c-70 with icu4c-71. [native-inputs]: Same. Efraim Flashner 2022-07-16gnu: node: Build with nghttp2@1.44.0....* gnu/packages/web.scm (nghttp2-for-node): New variable. * gnu/packages/node.scm (node, node-lts)[native-inputs, inputs]: Change from NGHTTP2 to NGHTTP2-FOR-NODE. Marius Bakke 2022-06-06gnu: node: Fix cross-compilation....* gnu/packages/node.scm (node)[phases]{configure}: Unwind the stack before invoking the exception handler. {patch-hardcoded-program-references}: Use search-input-file where appropriate. Jelle Licht 2022-06-06gnu: node-lts: Update to 14.19.3....* gnu/packages/node.scm (node-lts): Update to 14.19.3. [arguments]: Disable test that requires networking. [native-inputs]: Replace icu4c-67 with icu4c-70. [inputs]: Replace icu4c-67 with icu4c-70. Jelle Licht