aboutsummaryrefslogtreecommitdiff
Don't build the GCTP bundled with the source and link with the
system's -lgctp instead.  We also remove references to the
"testdrivers" directory, which is not distributed together with the
source, causing autoreconf to fail.

diff --git a/Makefile.in b/Makefile.in
index d468af2..90428a7 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -206,7 +206,7 @@ LIBGCTP = $(top_builddir)/gctp/src/libGctp.la
 @TESTDRIVERS_CONDITIONAL_TRUE@TESTDRIVERS = testdrivers
 @INSTALL_INCLUDE_CONDITIONAL_FALSE@INCLUDE = 
 @INSTALL_INCLUDE_CONDITIONAL_TRUE@INCLUDE = include
-SUBDIRS = gctp src $(INCLUDE) samples $(TESTDRIVERS)
+SUBDIRS = src $(INCLUDE) samples $(TESTDRIVERS)
 all: all-recursive
 
 .SUFFIXES:
diff --git a/include/Makefile.in b/include/Makefile.in
index 9938b23..afb7f40 100644
--- a/include/Makefile.in
+++ b/include/Makefile.in
@@ -190,7 +190,7 @@ LIBGCTP = $(top_builddir)/gctp/src/libGctp.la
 # Boilerplate include
 
 # Headers to install
-include_HEADERS = HE2_config.h HdfEosDef.h HDFEOSVersion.h cfortHdf.h ease.h
+include_HEADERS = HdfEosDef.h HDFEOSVersion.h cfortHdf.h ease.h
 all: HE2_config.h
 	$(MAKE) $(AM_MAKEFLAGS) all-am
 
diff --git a/samples/Makefile.in b/samples/Makefile.in
index 9da6e28..6a6186c 100644
--- a/samples/Makefile.in
+++ b/samples/Makefile.in
@@ -108,7 +108,6 @@ AppendField_SOURCES = AppendField.c
 AppendField_OBJECTS = AppendField.$(OBJEXT)
 AppendField_LDADD = $(LDADD)
 am__DEPENDENCIES_1 = $(top_builddir)/src/libhdfeos.la
-am__DEPENDENCIES_2 = $(top_builddir)/gctp/src/libGctp.la
 AppendField_DEPENDENCIES = $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_2)
 DefineFields_SOURCES = DefineFields.c
 DefineFields_OBJECTS = DefineFields.$(OBJEXT)
@@ -481,7 +480,7 @@ sharedstatedir = @sharedstatedir@
 sysconfdir = @sysconfdir@
 target_alias = @target_alias@
 LIBHDFEOS2 = $(top_builddir)/src/libhdfeos.la
-LIBGCTP = $(top_builddir)/gctp/src/libGctp.la
+LIBGCTP =
 
 # Boilerplate definitions file
 
-- 
2.10.0

se unstable tarball....Tobias Geerinckx-Rice 2019-02-16gnu: nanopass: Don't use unstable tarball....Tobias Geerinckx-Rice 2019-02-16gnu: chez-scheme: Return #t from all phases....Tobias Geerinckx-Rice 2019-02-16gnu: chez-scheme: Fix ‘install-doc’ phase....Tobias Geerinckx-Rice 2019-02-16gnu: chez-irregex: Don't use unstable tarball....Tobias Geerinckx-Rice 2019-02-16gnu: chez-matchable: Don't use unstable tarball....Tobias Geerinckx-Rice 2019-02-16gnu: chez-web: Use GIT- helpers....Tobias Geerinckx-Rice 2019-02-16gnu: chez-srfi: Don't use unstable tarball....Tobias Geerinckx-Rice 2019-02-16gnu: chez-fmt: Return #t from all phases....Tobias Geerinckx-Rice 2019-02-16gnu: chez-web: Return #t from all phases....Tobias Geerinckx-Rice 2018-12-14gnu: chez-sockets: Replace texlive input with minimal texlive-union....Pierre Neidhardt 2018-12-14gnu: chez-web: Replace texlive input with minimal texlive-union....Pierre Neidhardt 2018-12-14gnu: chez-web: Fix conflicting bootstrap phase....Pierre Neidhardt 2018-12-14gnu: chez-scheme: Replace texlive input with minimal texlive-union....Pierre Neidhardt 2018-10-16gnu: chez: Adjust to zlib static output....Marius Bakke 2018-03-16gnu: All snippets report errors using exceptions, else return #t....Mark H Weaver 2018-01-18gnu: chez-scheme: Fix build issues against glibc 2.26....Ludovic Courtès 2017-12-09gnu: chez-scheme: Update to 9.5....Tobias Geerinckx-Rice