aboutsummaryrefslogtreecommitdiff
Changes necessary for shared library linking to succeed.

diff --git a/src/Makefile.in b/src/Makefile.in
index 9534473..12411bf 100644
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -73,7 +73,7 @@ LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC) $(DEFS) \
 	$(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) \
 	$(AM_CFLAGS) $(CFLAGS)
 CCLD = $(CC)
-LINK = $(LIBTOOL) --mode=link --tag=CC $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+LINK = HDF4_USE_SHLIB=yes $(LIBTOOL) --mode=link --tag=CC $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
 	$(AM_LDFLAGS) $(LDFLAGS) -o $@
 SOURCES = $(libhdfeos_la_SOURCES)
 DIST_SOURCES = $(libhdfeos_la_SOURCES)
@@ -125,8 +125,6 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
 INSTALL_SCRIPT = @INSTALL_SCRIPT@
 INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
 
-# Set LDFLAGS to alow the HDF-EOS library to use extern variables from HDF4
-LDFLAGS = -Wl,-single_module
 LIBOBJS = @LIBOBJS@
 LIBS = @LIBS@
 LIBTOOL = @LIBTOOL@

59d'>gnu: reprotest: Update to 0.7.15....* gnu/packages/diffoscope (reprotest): Update to 0.7.15. [native-inputs] Add python-magic. Vagrant Cascadian 2020-10-24gnu: diffoscope: Update to 161....* gnu/packages/diffoscope (diffoscope): Update to 161. [arguments] Drop phases: dependency-on-python-magic, remove-ocaml-test, skip-elf-tests. Add phase skip-dex-test-when-missing-procyon. [inputs] Add python-magic. [native-inputs] Add python-black for tests. Vagrant Cascadian 2020-09-30gnu: Fix package references....* gnu/packages/algebra.scm (iml)[inputs]: Correctly refer to package inputs. * gnu/packages/astronomy.scm (xplanet), * gnu/packages/audio.scm (redkite, libaudec, lv2lint, lv2toweb), * gnu/packages/bioconductor.scm (r-cummerbund), * gnu/packages/chicken.scm (chicken), * gnu/packages/conky.scm (conky), * gnu/packages/cran.scm (r-latex2exp), * gnu/packages/crates-io.scm (rust-rgb), * gnu/packages/databases.scm (mariadb), * gnu/packages/diffoscope.scm (reprotest), * gnu/packages/file-systems.scm (glusterfs), * gnu/packages/finance.scm (electron-cash), * gnu/packages/games.scm (rinutils, ksudoku, kdiamond, kigo), * gnu/packages/geo.scm (grass), * gnu/packages/gnome.scm (libmediaart, gnome-contacts, geoclue), * gnu/packages/gnucash.scm (aqbanking), * gnu/packages/image.scm (mtpaint), * gnu/packages/kde-internet.scm (kopete, ktorrent), * gnu/packages/kde-utils.scm (kmousetool, kmouth, kronometer), * gnu/packages/linphone.scm (liblinphone), * gnu/packages/maths.scm (ppl), * gnu/packages/mercury.scm (mercury-minimal), * gnu/packages/music.scm (bjumblr, bschaffl, lsp-plugins, spectacle-analyzer, helm, tap-lv2, wolf-shaper, shiru-lv2), * gnu/packages/networking.scm (restinio), * gnu/packages/prolog.scm (swi-prolog), * gnu/packages/python-web.scm (gunicorn), * gnu/packages/python-xyz.scm (python-docusign-esign), * gnu/packages/ruby.scm (ruby-cucumber, ruby_version, ruby-addressable), * gnu/packages/sagemath.scm (python-cypari2), * gnu/packages/skarnet.scm (s6-linux-init), * gnu/packages/vpn.scm (sshuttle), * gnu/packages/web.scm (libcyaml), * gnu/packages/xdisorg.scm (kbdd), * gnu/packages/xorg.scm (xpra): Same. Efraim Flashner 2020-07-17gnu: diffoscope: Update to 151....* gnu/packages/diffoscope (diffoscope): Update to 151. Vagrant Cascadian 2020-07-03gnu: diffoscope: Update to 150....* gnu/packages/diffoscope (diffoscope): Update to 150. Vagrant Cascadian 2020-06-25gnu: diffoscope: Console widowed brackets....* gnu/packages/diffoscope.scm (diffoscope)[native-inputs]: Move closing brackets to the previous line. Tobias Geerinckx-Rice 2020-06-25gnu: diffoscope: Install the man page....* gnu/packages/diffoscope.scm (diffoscope)[arguments]: Add ‘build-man-page’ and ‘install-man-page’ phases. [native-inputs]: Add help2man. Tobias Geerinckx-Rice 2020-06-19gnu: diffoscope: Update to 148....* gnu/packages/diffoscope (diffoscope): Update to 148. [arguments] Remove add-known-tools phase, fixed upstream. Vagrant Cascadian 2020-06-14gnu: diffoscope: Update to 147....* gnu/packages/diffoscope (diffoscope): Update to 147. Vagrant Cascadian 2020-06-05gnu: diffoscope: Update to 146....* gnu/packages/diffoscope.scm (diffoscope): Update to 146. Tobias Geerinckx-Rice 2020-06-05gnu: diffoscope: Remove redundant let binding....* gnu/packages/diffoscope.scm (diffoscope): Unbind VERSION. Tobias Geerinckx-Rice 2020-05-25gnu: diffoscope: Update to 145....* gnu/packages/diffoscope (diffoscope): Update to 145. Vagrant Cascadian 2020-04-30gnu: diffoscope: Update to 143....* gnu/packages/diffoscope (diffoscope): Update to 143. [native-inputs]: Add openssl and python-h5py. [arguments] Add openssl to add-known-tools phase. [arguments] Remove hdf5 from add-known-tools phase, added upstream. Vagrant Cascadian 2020-04-17gnu: diffoscope.scm: Add missing import....This follows on from 2d9886f7e8838d6aeb0cfb20a2a49fc7d8fb233c. * gnu/packages/diffoscope.scm: Import (gnu packages maths). Christopher Baines 2020-04-16gnu: diffoscope: Update to 141....* gnu/packages/diffoscope (diffoscope): Update to 141. [arguments]: Add phase add-known-tools. [native-inputs]: Add hdf5. Vagrant Cascadian