unix_chkpwd is designed to have a suid bit, but it's not possible to set it for files in the store. This patch tells unix_pam.so to look for unix_chkpwd in setuid program directory on Guix System. --- a/modules/pam_unix/Makefile.in +++ b/modules/pam_unix/Makefile.in @@ -651,1 +651,1 @@ - -DCHKPWD_HELPER=\"$(sbindir)/unix_chkpwd\" \ + -DCHKPWD_HELPER=\"/run/setuid-programs/unix_chkpwd\" \ rowspan='2'>cgit logo index : guix
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
Skip 'test-stack-overflow' that crashes when using QEMU transparent emulation.

--- a/test-suite/standalone/Makefile.in	1970-01-01 01:00:01.000000000 +0100
+++ b/test-suite/standalone/Makefile.in	2021-01-11 10:59:31.606269449 +0100
@@ -102,8 +102,7 @@
 	test-scm-to-latin1-string$(EXEEXT) test-scm-values$(EXEEXT) \
 	test-scm-c-bind-keyword-arguments$(EXEEXT) \
 	test-srfi-4$(EXEEXT) $(am__append_6) $(am__EXEEXT_1) \
-	test-smob-mark$(EXEEXT) test-smob-mark-race$(EXEEXT) \
-	test-stack-overflow
+	test-smob-mark$(EXEEXT) test-smob-mark-race$(EXEEXT)
 check_PROGRAMS = test-num2integral$(EXEEXT) test-round$(EXEEXT) \
 	test-foreign-object-c$(EXEEXT) test-list$(EXEEXT) \
 	test-unwind$(EXEEXT) test-conversion$(EXEEXT) \
@@ -1938,7 +1937,7 @@
 	test-command-line-encoding test-command-line-encoding2 \
 	test-language test-guild-compile $(am__append_3) \
 	test-foreign-object-scm test-fast-slot-ref test-mb-regexp \
-	test-use-srfi $(am__append_5) test-stack-overflow
+	test-use-srfi $(am__append_5)
 BUILT_SOURCES = $(am__append_2)
 EXTRA_DIST = test-import-order-a.scm test-import-order-b.scm \
 	test-import-order-c.scm test-import-order-d.scm \