aboutsummaryrefslogtreecommitdiff
This patch makes GTK+ look for additional modules in a list of directories
specified by the environment variable "GUIX_GTK3_PATH".  This can be used
instead of "GTK_PATH" to make GTK+ find modules that are incompatible with
other major versions of GTK+.

--- a/gtk/gtkmodules.c	2015-09-20 20:09:05.060590217 +0200
+++ b/gtk/gtkmodules.c	2015-09-20 20:10:33.423124833 +0200
@@ -52,6 +52,7 @@
 get_module_path (void)
 {
   const gchar *module_path_env;
+  const gchar *module_guix_gtk3_path_env;
   const gchar *exe_prefix;
   gchar *module_path;
   gchar *default_dir;
@@ -61,6 +62,7 @@
     return result;
 
   module_path_env = g_getenv ("GTK_PATH");
+  module_guix_gtk3_path_env = g_getenv ("GUIX_GTK3_PATH");
   exe_prefix = g_getenv ("GTK_EXE_PREFIX");
 
   if (exe_prefix)
@@ -68,7 +70,13 @@
   else
     default_dir = g_build_filename (_gtk_get_libdir (), "gtk-3.0", NULL);
 
-  if (module_path_env)
+  if (module_guix_gtk3_path_env && module_path_env)
+    module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
+				module_guix_gtk3_path_env, module_path_env, default_dir, NULL);
+  else if (module_guix_gtk3_path_env)
+    module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
+				module_guix_gtk3_path_env, default_dir, NULL);
+  else if (module_path_env)
     module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
 				module_path_env, default_dir, NULL);
   else
u/packages/gcc.scm (gcc-9): Update to 9.2.0. Ludovic Courtès 2019-06-20gnu: isl: Update to 0.21....* gnu/packages/gcc.scm (isl): Update to 0.21. Marius Bakke 2019-06-20gnu: isl: Fix fallback URL....* gnu/packages/gcc.scm (isl, isl-0.18, isl-0.11)[source](uri): Use '.bz2' tarball. Marius Bakke 2019-05-25Merge branch 'staging' into core-updatesMarius Bakke 2019-05-22gnu: libstdc++-doc: Add version 9.x....* gnu/packages/gcc.scm (libstdc++-doc-4.9): Remove. (libstdc++-doc-9): New variable. Ludovic Courtès 2019-05-22gnu: libstdc++-doc: Unhide....This is a followup to d78010b81ee6ef4fd8803082e2f401b9e55b44db. * gnu/packages/gcc.scm (make-libstdc++-doc): Add 'properties' field. Ludovic Courtès 2019-05-16gnu: custom-gcc: Unhide resulting package....This is a follow-up to commit d78010b81ee6ef4fd8803082e2f401b9e55b44db. While the plain "gcc" packages should be hidden by default, gcc-derived packages like "gfortran" should not. * gnu/packages/gcc.scm (custom-gcc)[properties]: Remove the 'hidden? property. Ricardo Wurmus 2019-05-09gnu: gcc-4.7: Hide package....* gnu/packages/gcc.scm (gcc-4.7): Wrap in "hidden-package" expression. Ricardo Wurmus 2019-05-06gnu: gcc@9: Fix limits.h include for cross builds....This allows us to supply gcc-9 as an optional argument to cross-gcc, successfully constructing gcc-9-based cross-compilers. * gnu/packages/gcc.scm (gcc-9)[source](patches): Add "gcc-9-asan-fix-limits-include.patch". * gnu/packages/patches/gcc-9-asan-fix-limits-include.patch: New file. * gnu/local.mk (dist_patch_DATA): Add the patch. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Carl Dong 2019-05-06gnu: gcc: Add 9.1.0....* gnu/packages/gcc.scm (gcc-9): New variable. * gnu/packages/commencement.scm (gcc-toolchain-9): New variable. * gnu/packages/patches/gcc-9-strmov-store-file-names.patch: New file. * gnu/local.mk (dist_patch_DATA): Add the patch. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Carl Dong 2019-03-01Merge branch 'staging' into core-updatesMarius Bakke 2019-02-28gnu: GCC: Update to 8.3.0....* gnu/packages/gcc.scm (gcc-8): Update to 8.3.0. Marius Bakke