aboutsummaryrefslogtreecommitdiff
From d6d2caef3e44d0713bb6625f697a1ec615abae70 Mon Sep 17 00:00:00 2001
From: "Jan (janneke) Nieuwenhuizen" <janneke@gnu.org>
Date: Sun, 5 Apr 2020 16:29:54 +0200
Subject: [PATCH 4/4] misc: Choose a longer arbitrary line length.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This allows running specifying a `getty' in the GNU Guix store.

* misc/getttyent.c (MAXLINELENGTH): Use 512 (instead of 100) as
another "great" arbitrary limit.

Co-Authored-By: Ludovic Courtès <ludo@gnu.org>
---
 misc/getttyent.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/misc/getttyent.c b/misc/getttyent.c
index 92d92b026f..508d296291 100644
--- a/misc/getttyent.c
+++ b/misc/getttyent.c
@@ -66,7 +66,7 @@ __getttyent (void)
 	static struct ttyent tty;
 	int c;
 	char *p;
-#define	MAXLINELENGTH	100
+#define	MAXLINELENGTH	512
 	static char line[MAXLINELENGTH];
 
 	if (!tf && !__setttyent())
-- 
2.26.0

..* gnu/packages/bioinformatics.scm (vcflib)[arguments]: In custom generated pkg-config file, link with all needed libraries and fix linker library. * gnu/packages/patches/freebayes-devendor-deps.patch: Adjust accordingly. Efraim Flashner 2021-01-19gnu: freebayes: Don't include vcflib sources....* gnu/packages/bioinformatics.scm (freebayes)[native-inputs]: Remove vcflib-source, intervaltree-source. Move vcflib ... [inputs]: ... to here. [arguments]: Adjust 'patch-source and 'unpack-submodule-sources for changes in vendored code. * gnu/packages/patches/freebayes-devendor-deps.patch: Update patch. Efraim Flashner 2021-01-17gnu: freebayes: Update to 1.3.3....* gnu/packages/bioinformatics.scm (freebayes): Update to 1.3.3. [source]: Add patch. Add snippet to remove vendored library. [build-system]: Switch to meson-build-system. [inputs]: Remove bamtools. Add fastahack, smithwaterman, tabixpp. [native-inputs]: Remove procps, python-2, tabixpp source, smithwaterman source, multichoose source, fsom source, filevercmp source, fastahack source, bash-tap source. Add bash-tap, grep, pkg-config, simde, vcflib. [arguments]: Drop make-flags. Don't delete 'configure phase. Delete custom 'fix-tests, 'build-tabixpp-and-vcflib, 'fix-makefiles, 'install phases. Adjust 'unpack-submodule-sources phase to changed native-inputs. Add new 'patch-source phase. Efraim Flashner