aboutsummaryrefslogtreecommitdiff
Taken from https://salsa.debian.org/glibc-team/glibc/-/blob/5af8e3701c63ad202b652b5051bec592b8385820/debian/patches/hurd-i386/unsubmitted-getaux_at_secure.diff

This fixes gdk-pixbuf, gobject-introspection.

FIXME: sysdeps/mach/hurd/i386/init-first.c should instead pass an auxv
to __libc_start_main

Index: glibc-2.33/misc/getauxval.c
===================================================================
--- glibc-2.33.orig/misc/getauxval.c
+++ glibc-2.33/misc/getauxval.c
@@ -19,6 +19,7 @@
 #include <errno.h>
 #include <ldsodefs.h>
 #include <stdbool.h>
+#include <unistd.h>
 
 bool
 __getauxval2 (unsigned long int type, unsigned long int *result)
@@ -27,6 +28,14 @@ __getauxval2 (unsigned long int type, un
   ElfW(auxv_t) *p;
 #endif
 
+#ifdef AT_SECURE
+  if (type == AT_SECURE)
+    {
+      *result = __libc_enable_secure;
+      return true;
+    }
+#endif
+
   if (type == AT_HWCAP)
     {
       *result = GLRO(dl_hwcap);
PostgreSQL will reject the data files from the differing major version of the service. Because it's important to either keep running a particular major version, or intentionally upgrade, I think the configuration would be better with no default. I think this is also going to be helpful when trying to assist users upgrading PostgreSQL. * gnu/services/databases.scm (<postgresql-configuration>): Remove default for postgresql. (postgresql-service-type): Remove the default value. * gnu/tests/databases.scm (%postgresql-os): Update accordingly. * gnu/tests/guix.scm (%guix-data-service-os): Update accordingly. * gnu/tests/monitoring.scm (%zabbix-os): Update accordingly. * gnu/tests/web.scm (patchwork-os): Update accordingly. * doc/guix.texi (PostgreSQL): Update accordingly. 2020-07-13gnu: tests: Fix unbound variable.Julien Lepiller Record type descriptors were made private in a143e92446859bd1edc7a7aea85b2089c82c77da, but a usage of them was forgotten in the tests files. * gnu/tests/web.scm (patchwork-initial-database-setup-service): Use accessors to access field values instead of unexported type descriptor. 2020-04-21tests: web: Explicitly wait for the HTTP port.Ludovic Courtès * gnu/tests/web.scm (run-webserver-test)["HTTP port ready"]: New test. 2019-05-31services: Add patchwork.Christopher Baines * gnu/service/web.scm (<patchwork-database-configuration> <patchwork-settings-module>, <patchwork-configuration>): New record types. (patchwork-virtualhost): New procedure. (patchwork-service-type): New variable. * gnu/tests/web.scm (%test-patchwork): New variable. * doc/guix.text (Web Services): Document it.