aboutsummaryrefslogtreecommitdiff
Do not attempt to dlopen PIE objects, which was disallowed with glibc 2.30.

https://gitlab.haskell.org/ghc/ghc/issues/17952
https://sourceware.org/bugzilla/show_bug.cgi?id=24323

Patch submitted upstream:
https://gitlab.haskell.org/ghc/ghc/-/merge_requests/2947

diff --git a/testsuite/tests/dynlibs/Makefile b/testsuite/tests/dynlibs/Makefile
--- a/testsuite/tests/dynlibs/Makefile
+++ b/testsuite/tests/dynlibs/Makefile
@@ -60,6 +60,4 @@ T5373:
 .PHONY: T13702
 T13702:
 	'$(TEST_HC)' -v0 -dynamic -rdynamic -fPIC -pie T13702.hs
-	'$(TEST_HC)' -v0 -dynamic T13702a.hs
-	./T13702  # first make sure executable itself works
-	./T13702a # then try dynamically loading it as library
+	./T13702
diff --git a/testsuite/tests/dynlibs/T13702.hs b/testsuite/tests/dynlibs/T13702.hs
--- a/testsuite/tests/dynlibs/T13702.hs
+++ b/testsuite/tests/dynlibs/T13702.hs
@@ -2,8 +2,3 @@
 
 main :: IO ()
 main = putStrLn "hello world"
-
-foreign export ccall "hello" hello :: IO ()
-
-hello :: IO ()
-hello = putStrLn "hello world again"
diff --git a/testsuite/tests/dynlibs/T13702.stdout b/testsuite/tests/dynlibs/T13702.stdout
--- a/testsuite/tests/dynlibs/T13702.stdout
+++ b/testsuite/tests/dynlibs/T13702.stdout
@@ -1,2 +1 @@
 hello world
-hello world again
diff --git a/testsuite/tests/dynlibs/T13702a.hs b/testsuite/tests/dynlibs/T13702a.hs
deleted file mode 100644
--- a/testsuite/tests/dynlibs/T13702a.hs
+++ /dev/null
@@ -1,12 +0,0 @@
-{-# LANGUAGE ForeignFunctionInterface #-}
-
-import Foreign
-import System.Posix.DynamicLinker
-
-main :: IO ()
-main = do
-    dl <- dlopen "./T13702" [RTLD_NOW]
-    funptr <- dlsym dl "hello" :: IO (FunPtr (IO ()))
-    mkAction funptr
-
-foreign import ccall "dynamic" mkAction :: FunPtr (IO ()) -> IO ()
axim Cournoyer 2021-05-31gnu: gnuastro: Update to 0.15....* gnu/packages/astronomy.scm (gnuastro): Update to 0.15. Efraim Flashner 2021-05-07gnu: Add sgp4....* gnu/packages/astronomy.scm (sgp4): New variable. Guillaume Le Vaillant 2021-05-04gnu: indi: Stop returning #t from phases....* gnu/packages/astronomy.scm (indi)[arguments]: Remove #t phase return values. Tobias Geerinckx-Rice 2021-05-04gnu: indi: Respect #:tests?....* gnu/packages/astronomy.scm (indi)[arguments]: Respect #:tests? in the 'check phase. Tobias Geerinckx-Rice 2021-05-04gnu: indi: Check slightly more functionally....* gnu/packages/astronomy.scm (indi)[arguments]: Substitute WITH-DIRECTORY-EXCURSION for double CHDIR. Tobias Geerinckx-Rice 2021-05-04gnu: indi: Update to 1.9.0....* gnu/packages/astronomy.scm (indi): Update to 1.9.0. Tobias Geerinckx-Rice 2021-05-03gnu: python-asdf: Update to 2.7.4....* gnu/packages/astronomy.scm (python-asdf): Update to 2.7.4. Tobias Geerinckx-Rice 2021-04-27gnu: python-skyfield: Match up input and variable names....* gnu/packages/astronomy.scm (python-skyfield)[inputs]: Add "python-" prefix to alist keys. Tobias Geerinckx-Rice 2021-04-27gnu: python-skyfield: Update to 1.39....* gnu/packages/astronomy.scm (python-skyfield): Update to 1.39. Tobias Geerinckx-Rice 2021-04-27gnu: python-pyerfa: Update to 1.7.3....* gnu/packages/astronomy.scm (python-pyerfa): Update to 1.7.3. Tobias Geerinckx-Rice 2021-04-11gnu: python-skyfield: Update to 1.38....* gnu/packages/astronomy.scm (python-skyfield): Update to 1.38. Tobias Geerinckx-Rice 2021-04-10gnu: erfa: Mark up description....* gnu/packages/astronomy.scm (erfa)[description]: Add all the @acronym{}s. Tobias Geerinckx-Rice 2021-04-10gnu: erfa: Update to 1.7.3....* gnu/packages/astronomy.scm (erfa): Update to 1.7.3. Tobias Geerinckx-Rice 2021-04-09gnu: stellarium: Update to 0.21.0....* gnu/packages/astronomy.scm (stellarium): Update to 0.21.0. Tobias Geerinckx-Rice 2021-03-21gnu: wcslib: Update to 7.5....* gnu/packages/astronomy.scm (wcslib): Update to 7.5. Tobias Geerinckx-Rice 2021-03-04gnu: indi: Update to 1.8.9....* gnu/packages/astronomy.scm (indi): Update to 1.8.9. Tobias Geerinckx-Rice 2021-02-28gnu: python-asdf: Use HTTPS home page URI....* gnu/packages/astronomy.scm (python-asdf)[home-page]: Use HTTPS URI. Nicolas Goaziou 2021-02-21gnu: Add asdf (Advanced Scientific Data Format)...* gnu/packages/astronomy.scm (python-asdf): New variable Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Sharlatan Hellseher 2021-02-21gnu: wcslib: Update to 7.4...* gnu/packages/astronomy.scm (wcslib): Update to 7.4 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Sharlatan Hellseher 2021-02-19gnu: Add stackistry....* gnu/packages/astronomy.scm (stackistry): New variable. Co-authored-by: Guillaume Le Vaillant <glv@posteo.net> Sharlatan Hellseher 2021-02-19gnu: Add libskry....* gnu/packages/astronomy.scm (libskry): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Sharlatan Hellseher 2021-02-19gnu: Add python-astroalign....* gnu/packages/astronomy.scm (python-astroalign): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Sharlatan Hellseher 2021-02-19gnu: Add python-sep....* gnu/packages/astronomy.scm (python-sep): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Sharlatan Hellseher 2021-02-19gnu: Add python-pyerfa....* gnu/packages/astronomy.scm (python-pyerfa): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Sharlatan Hellseher 2021-02-19gnu: Add erfa....* gnu/packages/astronomy.scm (erfa): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Sharlatan Hellseher 2021-02-19gnu: Add qfits....* gnu/packages/astronomy.scm (qfits): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Sharlatan Hellseher 2021-02-19gnu: Add python-skyfield....* gnu/packages/astronomy.scm (python-skyfield): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Sharlatan Hellseher 2021-02-07gnu: Add jplephem...* gnu/packages/astronomy.scm (python-jplephem): New variable Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Sharlatan Hellseher 2021-01-31gnu: Add indi....* gnu/packages/astronomy.scm (indi): New variable. Co-authored-by: Guillaume Le Vaillant <glv@posteo.net> Sharlatan Hellseher 2021-01-29gnu: Add weightwatcher....* gnu/packages/astronomy.scm (weightwatcher): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Sharlatan Hellseher 2021-01-29gnu: Add swarp....* gnu/packages/astronomy.scm (swarp): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Sharlatan Hellseher 2021-01-29gnu: Add stuff....* gnu/packages/astronomy.scm (stuff): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Sharlatan Hellseher 2021-01-28gnu: Add skymaker....* gnu/packages/astronomy.scm (skymaker): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Sharlatan Hellseher 2021-01-27gnu: Add missfits....* gnu/packages/astronomy.scm (missfits): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Sharlatan Hellseher 2021-01-26gnu: Add eye....* gnu/packages/astronomy.scm (eye): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Sharlatan Hellseher 2021-01-25gnu: gnuastro: Update to 0.14....* gnu/packages/astronomy.scm (gnuastro): Update to 0.14. [inputs]: Add curl-minimal, libgit2. Efraim Flashner 2021-01-25gnu: Add sextractor....* gnu/packages/astronomy.scm (sextractor): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Sharlatan Hellseher 2021-01-25gnu: Add libpasastro....* gnu/packages/astronomy.scm (libpasastro): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Sharlatan Hellseher