aboutsummaryrefslogtreecommitdiff
Revert upstream commit 04bb9a08b3c25f8e3c0c235f9cefc0f94df59a5a because it
causes a test failure on i686 and possibly other architectures.

See <https://github.com/libgd/libgd/issues/613>.

diff --git a/src/gdft.c b/src/gdft.c
--- a/src/gdft.c
+++ b/src/gdft.c
@@ -1579,6 +1579,12 @@ BGD_DECLARE(char *) gdImageStringFTEx (gdImage * im, int *brect, int fg, const c
 		double scalex = (double)hdpi / (64 * METRIC_RES);
 		double scaley = (double)vdpi / (64 * METRIC_RES);
 
+		/* increase by 1 pixel to allow for rounding */
+		total_min.x -= METRIC_RES;
+		total_min.y -= METRIC_RES;
+		total_max.x += METRIC_RES;
+		total_max.y += METRIC_RES;
+
 		/* rotate bounding rectangle, scale and round to int pixels, and translate */
 		brect[0] = x + (total_min.x * cos_a + total_max.y * sin_a)*scalex;
 		brect[1] = y - (total_min.x * sin_a - total_max.y * cos_a)*scaley;
diff --git a/tests/gdimagestringft/gdimagestringft_bbox.c b/tests/gdimagestringft/gdimagestringft_bbox.c
--- a/tests/gdimagestringft/gdimagestringft_bbox.c
+++ b/tests/gdimagestringft/gdimagestringft_bbox.c
@@ -8,22 +8,22 @@
 #define DELTA (PI/8)
 
 static int EXPECT[16][8] = {
-	{500, 400, 628, 400, 628, 376, 500, 376},
-	{492, 362, 611, 312, 601, 290, 483, 339},
-	{470, 330, 561, 239, 544, 221, 453, 312},
-	{437, 308, 486, 189, 464, 180, 414, 299},
-	{400, 301, 400, 173, 376, 173, 376, 301},
-	{363, 309, 313, 190, 291, 200, 340, 318},
-	{332, 331, 241, 240, 223, 257, 314, 348},
-	{311, 363, 192, 314, 183, 336, 302, 386},
-	{304, 399, 176, 399, 176, 423, 304, 423},
-	{312, 435, 193, 485, 203, 507, 321, 458},
-	{333, 465, 242, 556, 259, 574, 350, 483},
-	{364, 486, 315, 605, 337, 614, 387, 495},
-	{399, 492, 399, 620, 423, 620, 423, 492},
-	{434, 484, 484, 603, 506, 593, 457, 475},
-	{463, 464, 554, 555, 572, 538, 481, 447},
-	{483, 434, 602, 483, 611, 461, 492, 411},
+	{498, 401, 630, 401, 630, 374, 498, 374},
+	{491, 364, 613, 313, 602, 288, 481, 338},
+	{470, 332, 563, 239, 544, 219, 451, 312},
+	{438, 310, 488, 189, 463, 178, 412, 300},
+	{401, 303, 401, 171, 374, 171, 374, 303},
+	{365, 310, 314, 188, 289, 199, 339, 320},
+	{334, 331, 241, 238, 221, 257, 314, 350},
+	{313, 362, 192, 312, 181, 337, 303, 388},
+	{306, 398, 174, 398, 174, 425, 306, 425},
+	{313, 433, 191, 484, 202, 509, 323, 459},
+	{333, 463, 240, 556, 259, 576, 352, 483},
+	{363, 484, 313, 605, 338, 616, 389, 494},
+	{398, 490, 398, 622, 425, 622, 425, 490},
+	{432, 483, 483, 605, 508, 594, 458, 473},
+	{461, 464, 554, 557, 574, 538, 481, 445},
+	{481, 435, 602, 485, 613, 460, 491, 409},
 };
 
 int main()
m, gnu/packages/benchmark.scm, gnu/packages/bioconductor.scm, gnu/packages/bioinformatics.scm, gnu/packages/bittorrent.scm, gnu/packages/boost.scm, gnu/packages/build-tools.scm, gnu/packages/c.scm, gnu/packages/calendar.scm, gnu/packages/cdrom.scm, gnu/packages/check.scm, gnu/packages/chemistry.scm, gnu/packages/chez.scm, gnu/packages/clojure.scm, gnu/packages/code.scm, gnu/packages/compression.scm, gnu/packages/compton.scm, gnu/packages/coq.scm, gnu/packages/cpp.scm, gnu/packages/cran.scm, gnu/packages/crypto.scm, gnu/packages/curl.scm, gnu/packages/databases.scm, gnu/packages/datastructures.scm, gnu/packages/debug.scm, gnu/packages/disk.scm, gnu/packages/distributed.scm, gnu/packages/django.scm, gnu/packages/dlang.scm, gnu/packages/dns.scm, gnu/packages/docker.scm, gnu/packages/education.scm, gnu/packages/efi.scm, gnu/packages/elixir.scm, gnu/packages/emacs-xyz.scm, gnu/packages/embedded.scm, gnu/packages/emulators.scm, gnu/packages/engineering.scm, gnu/packages/erlang.scm, gnu/packages/fabric-management.scm, gnu/packages/file-systems.scm, gnu/packages/finance.scm, gnu/packages/firmware.scm, gnu/packages/flashing-tools.scm, gnu/packages/fonts.scm, gnu/packages/fontutils.scm, gnu/packages/fpga.scm, gnu/packages/game-development.scm, gnu/packages/games.scm, gnu/packages/genealogy.scm, gnu/packages/genimage.scm, gnu/packages/geo.scm, gnu/packages/gimp.scm, gnu/packages/gl.scm, gnu/packages/gnome-xyz.scm, gnu/packages/gnome.scm, gnu/packages/gnuzilla.scm, gnu/packages/golang.scm, gnu/packages/gpodder.scm, gnu/packages/graph.scm, gnu/packages/graphics.scm, gnu/packages/graphviz.scm, gnu/packages/groff.scm, gnu/packages/groovy.scm, gnu/packages/gtk.scm, gnu/packages/guile-xyz.scm, gnu/packages/guile.scm, gnu/packages/hardware.scm, gnu/packages/haskell-apps.scm, gnu/packages/haskell-xyz.scm, gnu/packages/hexedit.scm, gnu/packages/i2p.scm, gnu/packages/ibus.scm, gnu/packages/image-processing.scm, gnu/packages/image-viewers.scm, gnu/packages/image.scm, gnu/packages/ipfs.scm, gnu/packages/java-graphics.scm, gnu/packages/java-maths.scm, gnu/packages/java.scm, gnu/packages/javascript.scm, gnu/packages/jrnl.scm, gnu/packages/julia.scm, gnu/packages/jupyter.scm, gnu/packages/kodi.scm, gnu/packages/language.scm, gnu/packages/lego.scm, gnu/packages/less.scm, gnu/packages/libusb.scm, g2020-03-16tests: opensmtpd: Check /var/spool/mail instead of /var/mail....The test had been failing since the upgrade to 6.6.3p1 in commit 2dbfd8eec43b602d23cee3fdd2842cc333e36c24. * gnu/services/mail.scm (opensmtpd-activation): Create /var/spool/mail. * gnu/tests/mail.scm (run-opensmtpd-test): Check /var/spool/mail instead of /var/mail. Ludovic Courtès 2020-03-16tests: opensmtpd: Gracefully handle test failure....Previously the 'wait' loop would run for ~1024 seconds, at which point we'd reach the file descriptor limit due to the leak in 'queue-empty?'. * gnu/tests/mail.scm (run-opensmtpd-test)[test]("mail arrived"): In 'queue-empty?', close PIPE to avoid file descriptor leak. In 'wait' loop, arrange to run at most 20 times. Ludovic Courtès 2020-03-09tests: getmail: Provide a pre-initialized user account password....* gnu/tests/mail.scm (%getmail-os): Rewrite so that the "alice" account has a password. (run-getmail-test)[test]("set password for alice"): Remove. This would not work since commit 8b9cad01e9619f53dc5a65892ca6a09ca5de3447 since 'passwd' would no longer be in $PATH. Ludovic Courtès 2020-01-31gnu: Update opensmtpd configuration grammar....This follows up on commit 0d486909083c98d7c75cdfc027f89e69f9bf8f48. * gnu/services/mail.scm (%default-opensmtpd-config-file): Adapt to ‘new’ ≥6.4 grammar. * gnu/tests/mail.scm (%opensmtpd-os): Likewise. Tobias Geerinckx-Rice <2020-04-08gnu: genimage: Update to 11.Vincent Legoll * gnu/packages/genimage.scm (genimage): Update to 11, [arguments]: add a new test dump file to the patche2019-06-19tests: Fix opensmtpd test....* gnu/tests/mail.scm (run-opensmtpd-test) <"mail arrived">: Invoke smtpctl by its full file name. Tobias Geerinckx-Rice 2019-05-31services: Add getmail....Getmail is a mail retriever written in Python, this commit adds a service-type to run getmail. I'm looking at this, as it's a convinient way of getting mailing list messages in to Patchwork. I initially tried putting this in the (gnu services mail) module, but due to also trying to use the define-configuration pattern, it conflicted with the dovecot service. * gnu/services/getmail.scm: New file. * gnu/local.mk: Add it. * gnu/tests/mail.scm (%getmail-os, %test-getmail): New variables. (run-getmail-test): New procedure. Christopher Baines