aboutsummaryrefslogtreecommitdiff
Search path environment variables for cross-compilers.  See the discussion
at <http://gcc.gnu.org/ml/gcc/2013-02/msg00124.html>.

Note: Touch 'C_INCLUDE_PATH' et al. rather than 'CPATH', as discussed
at <http://bugs.gnu.org/22186>.

--- a/gcc/incpath.c
+++ b/gcc/incpath.c
@@ -461,8 +461,8 @@ register_include_chains (cpp_reader *pfile, const char *sysroot,
 			 int stdinc, int cxx_stdinc, int verbose)
 {
   static const char *const lang_env_vars[] =
-    { "C_INCLUDE_PATH", "CPLUS_INCLUDE_PATH",
-      "OBJC_INCLUDE_PATH", "OBJCPLUS_INCLUDE_PATH" };
+    { "CROSS_C_INCLUDE_PATH", "CROSS_CPLUS_INCLUDE_PATH",
+      "CROSS_OBJC_INCLUDE_PATH", "CROSS_OBJCPLUS_INCLUDE_PATH" };
   cpp_options *cpp_opts = cpp_get_options (pfile);
   size_t idx = (cpp_opts->objc ? 2: 0);
 
@@ -473,7 +473,7 @@ register_include_chains (cpp_reader *pfile, const char *sysroot,
 
   /* CPATH and language-dependent environment variables may add to the
      include chain.  */
-  add_env_var_paths ("CPATH", BRACKET);
+  add_env_var_paths ("CROSS_CPATH", BRACKET);
   add_env_var_paths (lang_env_vars[idx], SYSTEM);
 
   target_c_incpath.extra_pre_includes (sysroot, iprefix, stdinc);
diff --git a/gcc/system.h b/gcc/system.h
index 42bc509..af3b9ad 100644
--- a/gcc/system.h
+++ b/gcc/system.h
@@ -1063,4 +1063,6 @@ helper_const_non_const_cast (const char *p)
 /* Get definitions of HOST_WIDE_INT and HOST_WIDEST_INT.  */
 #include "hwint.h"
 
+#define LIBRARY_PATH_ENV "CROSS_LIBRARY_PATH"
+
 #endif /* ! GCC_SYSTEM_H */
diff --git a/gcc/tlink.c b/gcc/tlink.c
index bc358b8..ad6242f 100644
--- a/gcc/tlink.c
+++ b/gcc/tlink.c
@@ -458,7 +458,7 @@ recompile_files (void)
   file *f;
 
   putenv (xstrdup ("COMPILER_PATH="));
-  putenv (xstrdup ("LIBRARY_PATH="));
+  putenv (xstrdup (LIBRARY_PATH_ENV "="));
 
   while ((f = file_pop ()) != NULL)
     {
diff --git a/gcc/gcc.c b/gcc/gcc.c
index adbf0c4..70448c6 100644
--- a/gcc/gcc.c
+++ b/gcc/gcc.c
@@ -3853,7 +3853,7 @@ process_command (unsigned int decoded_options_count,
     }
 
   temp = getenv (LIBRARY_PATH_ENV);
-  if (temp && *cross_compile == '0')
+  if (temp)
     {
       const char *startp, *endp;
       char *nstore = (char *) alloca (strlen (temp) + 3);
ariable. Signed-off-by: Timothy Sample <samplet@ngyro.com> Giacomo Leidi 2020-12-06gnu: Add ghc-yesod-test....* gnu/packages/haskell-web.scm (ghc-yesod-test): New variable. Signed-off-by: Timothy Sample <samplet@ngyro.com> Giacomo Leidi 2020-12-06gnu: ghc-yesod-core: Update to 1.6.17.2....* gnu/packages/haskell-web.scm (ghc-yesod-core): Update to 1.6.17.2. Signed-off-by: Timothy Sample <samplet@ngyro.com> Giacomo Leidi 2020-11-20gnu: Add ghc-http-reverse-proxy....* gnu/packages/haskell-web.scm (ghc-http-reverse-proxy): New variable. Alexandru-Sergiu Marton 2020-09-23gnu: Fix typoes in package descriptions....* gnu/packages/audio.scm (caps-plugins-lv2)[synopsis]: Fix typo. * gnu/packages/bioconductor.scm (r-karyoploter, r-anota, r-gcrma) (r-bigmemoryextras)[description]: Likewise. * gnu/packages/cran.scm (r-geometry)[synopsis]: Likewise. (r-stringdist, r-patchwork, r-depth, r-tea)[description]: Likewise. * gnu/packages/crates-io.scm (rust-assert-fs-0.11, rust-notify-4) (rust-tokio-fs-0.1)[synopsis, description]: Likewise. (rust-blas-sys-0.7)[description]: Likewise. (rust-fs-extra-1.1, rust-xattr-0.2)[synopsis]: Likewise. * gnu/packages/databases.scm (perl-mysql-config)[description]: Likewise. * gnu/packages/disk.scm (hddtemp)[description]: Likewise. * gnu/packages/django.scm (python-djangorestframework)[description]: Likewise. * gnu/packages/documentation.scm (doc++)[description]: Likewise. * gnu/packages/emacs-xyz.scm (emacs-kakoune, emacs-pyim-basedict, eless) (emacs-scpaste)[description]: Likewise. * gnu/packages/file-systems.scm (dbxfs)[description]: Likewise. * gnu/packages/finance.scm (python-stdnum)[description]: Likewise. * gnu/packages/fontutils.scm (woff2)[description]: Likewise. * gnu/packages/games.scm (openttd-opengfx)[description]: Likewise. * gnu/packages/gnome-xyz.scm (gnome-shell-extension-topicons-redux) [description]: Likewise. * gnu/packages/gnome.scm (libgrss)[description]: Likewise. * gnu/packages/golang.scm (go-github-com-mitchellh-reflectwalk) [description]: Likewise. (go-github-com-go-git-go-billy)[synopsis, description]: Likewise. * gnu/packages/haskell-check.scm (ghc-inspection-testing)[description]: Likewise. * gnu/packages/haskell-web.scm (ghc-yesod-form)[description]: Likewise. * gnu/packages/haskell-xyz.scm (ghc-hex)[description]: Likewise. * gnu/packages/hyperledger.scm (hyperledger-iroha-ed25519)[description]: Likewise. * gnu/packages/java.scm (java-mail)[synopsis]: Likewise. (java-native-access-platform)[description]: Likewise. * gnu/packages/kde-frameworks.scm (kactivities-stats)[description]: Likewise. * gnu/packages/kde-utils.scm (krusader)[description]: Likewise. * gnu/packages/language.scm (praat)[description]: Likewise. * gnu/packages/linux.scm (light)[description]: Likewise. * gnu/packages/lisp-xyz.scm (sbcl-hu.dwim.defclass-star)[description]: Likewise. * gnu/packages/mail.scm (dovecot-trees, sieve-connect)[description]: Likewise. * gnu/packages/ocaml.scm (ocaml-opam-file-format, ocaml-cppo) (ocaml4.07-ppx-variants-conv)[description]: Likewise. * gnu/packages/perl.scm (perl-convert-binhex)[description]: Likewise. * gnu/packages/python-crypto.scm (python-ecdsa)[description]: Likewise. * gnu/packages/python-web.scm (python-html5lib)[synopsis, description]: Likewise. (python-venusian)[synopsis]: Likewise. * gnu/packages/python-xyz.scm (python-readlike, python-gssapi) (python-flufl-i18n)[description]: Likewise. (python-pox, python-watchdog, python-xattr)[synopsis, description]: Likewise. * gnu/packages/ruby.scm (ruby-sorcerer)[description]: Likewise. * gnu/packages/rust-apps.scm (watchexec)[description]: Likewise. * gnu/packages/rust.scm (mrustc)[synopsis]: Likewise. * gnu/packages/shells.scm (s-shell)[description]: Likewise. * gnu/packages/ssh.scm (sshpass)[description]: Likewise. * gnu/packages/terminals.scm (beep)[description]: Likewise. * gnu/packages/web.scm (perl-lwp-useragent-cached)[description]: Likewise. * gnu/packages/wv.scm (wv)[description]: Likewise. Tobias Geerinckx-Rice 2020-09-08gnu: Add ghc-dav....* gnu/packages/haskell-web.scm (ghc-dav): New variable. Signed-off-by: Timothy Sample <samplet@ngyro.com> Kyle Meyer 2020-08-13gnu: ghc-http: Prevent embedding of spurious references....* gnu/packages/haskell-web.scm (ghc-http)[arguments]: Add build phase "create-simple-paths-module" to avoid retaining unnecessary references. Ricardo Wurmus 2020-08-13gnu: ghc-hxt: Add "doc" output....* gnu/packages/haskell-web.scm (ghc-hxt)[outputs]: Add "doc" output next to "out" and "static". Ricardo Wurmus 2020-08-13gnu: ghc-aeson: Add "doc" output....* gnu/packages/haskell-web.scm (ghc-aeson)[outputs]: Add "doc" output next to "out" and "static". Ricardo Wurmus 2020-08-13gnu: ghc-blaze-html: Add "doc" output....* gnu/packages/haskell-web.scm (ghc-blaze-html)[outputs]: Add "doc" output next to "out" and "static". Ricardo Wurmus 2020-08-13gnu: Add "static" output to Haskell packages with custom outputs....All these packages have non-standard outputs. As a result the build system cannot automatically add the "static" output, so we do this manually. * gnu/packages/haskell-check.scm (ghc-quickcheck, ghc-hunit)[outputs]: Add "static" output. * gnu/packages/haskell-web.scm (ghc-http)[outputs]: Same. * gnu/packages/haskell-xyz.scm (ghc-case-insensitive, ghc-fgl, ghc-hashable, ghc-network, ghc-network-uri, ghc-parallel, ghc-paths, ghc-primitive, ghc-random, ghc-split, ghc-syb, ghc-tf-random, ghc-unordered-containers, ghc-vector, ghc-zlib)[outputs]: Same. Ricardo Wurmus 2020-07-16gnu: Use HTTPS for www.yesodweb.com....* gnu/packages/haskell-web.scm (ghc-css-text, ghc-yesod-persistent) [home-page]: Use HTTPS. Tobias Geerinckx-Rice 2020-07-16gnu: Use HTTPS for github.com (and subdomains) home pages....* gnu/packages/bioconductor.scm (r-qvalue)[home-page]: Use HTTPS and follow permanent redirection. * gnu/packages/check.scm (python-codecov, python-nosexcover) [home-page]: Likewise. * gnu/packages/cran.scm (r-ffbase, r-ggrepel, r-valr) [home-page]: Likewise. * gnu/packages/crates-io.scm (rust-block-0.1, rust-dispatch-0.1) (rust-objc-0.2, rust-objc-exception-0.1) (rust-objc-foundation-0.1, rust-objc-id-0.1, rust-objc-test-utils-0.0) (rust-onig-5.0, rust-onig-sys-69.2, rust-vergen-3.1) [home-page]: Likewise. * gnu/packages/finance.scm (ledger-agent, keepkey-agent) [home-page]: Likewise. * gnu/packages/haskell-check.scm (ghc-tasty-expected-failure) [home-page]: Likewise. * gnu/packages/haskell-web.scm (ghc-bsb-http-chunked, ghc-warp) (ghc-warp-tls)[home-page]: Likewise. * gnu/packages/haskell-xyz.scm (ghc-configurator, ghc-hasktags) (ghc-linear, ghc-newtype-generics, ghc-retry, ghc-xdg-basedir) (ghc-pretty-show)[home-page]: Likewise. * gnu/packages/java.scm (java-javax-inject)[home-page]: Likewise. * gnu/packages/libffi.scm (ruby-ffi)[home-page]: Likewise. * gnu/packages/linux.scm (procenv)[home-page]: Likewise. * gnu/packages/python-web.scm (python-aiodns, python-flask-htpasswd) (python-pycares)[home-page]: Likewise. * gnu/packages/python-xyz.scm (python-progressbar33, python-whatever) (python-funcy)[home-page]: Likewise. * gnu/packages/ruby.scm (ruby-rubyzip, ruby-spinach, ruby-gherkin-ruby) (ruby-code-statistics, ruby-colorize, ruby-wwtd)[home-page]: Likewise. Tobias Geerinckx-Rice 2020-07-16gnu: Update Haskell Wiki URIs....* gnu/packages/haskell-web.scm (ghc-hxt-regex-xmlschema)[home-page]: Use HTTPS and follow permanent redirection. * gnu/packages/haskell-xyz.scm (ghc-alsa-core, ghc-base-unicode-symbols) (ghc-colour, ghc-data-accessor, ghc-data-accessor-transformers) (ghc-gluraw, ghc-glut, ghc-gnuplot, ghc-haddock-test, ghc-opengl) (ghc-openglraw, ghc-storablevector)[home-page]: Likewise. Tobias Geerinckx-Rice