aboutsummaryrefslogtreecommitdiff
Revert the following commit to work around a bootstrap comparison failure on
ARMv7, as reported at <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=71399>.

commit f6ab85b7049a03962ea98924d00802da357a1ad3
Author: renlin <renlin@138bc75d-0d04-0410-961f-82ee72b054a4>
Date:   Wed Dec 2 14:06:31 2015 +0000

    [PR67383][ARM][4.9]Backport of "Allow any register for DImode values in Thumb2"
    
    This partially fix PR67383. It allows the reload more flexibility to choose
    spilling pseudo registers.
    
    
    gcc/ChangeLog:
    
    2015-12-02  Renlin Li  <renlin.li@arm.com>
    
            Backport from mainline.
            2014-04-22  Ramana Radhakrishnan <ramana.radhakrishnan@arm.com>
    
            * config/arm/arm.c (arm_hard_regno_mode_ok): Loosen
            restrictions on core registers for DImode values in Thumb2.
    
    
    git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/branches/gcc-4_9-branch@231177 138bc75d-0d04-0410-961f-82ee72b054a4

diff --git a/gcc/config/arm/arm.c b/gcc/config/arm/arm.c
index 8ba6060..d9028a1 100644
--- b/gcc/config/arm/arm.c
+++ a/gcc/config/arm/arm.c
@@ -22624,19 +22624,12 @@
     }
 
   /* We allow almost any value to be stored in the general registers.
-     Restrict doubleword quantities to even register pairs in ARM state
-     so that we can use ldrd.  Do not allow very large Neon structure
-     opaque modes in general registers; they would use too many.  */
+     Restrict doubleword quantities to even register pairs so that we can
+     use ldrd.  Do not allow very large Neon structure opaque modes in
+     general registers; they would use too many.  */
   if (regno <= LAST_ARM_REGNUM)
-    {
-      if (ARM_NUM_REGS (mode) > 4)
-	  return FALSE;
-
-      if (TARGET_THUMB2)
-	return TRUE;
-
-      return !(TARGET_LDRD && GET_MODE_SIZE (mode) > 4 && (regno & 1) != 0);
-    }
+    return !(TARGET_LDRD && GET_MODE_SIZE (mode) > 4 && (regno & 1) != 0)
+      && ARM_NUM_REGS (mode) <= 4;
 
   if (regno == FRAME_POINTER_REGNUM
       || regno == ARG_POINTER_REGNUM)
af6a634a87608b4ae54ca'>gnu: talloc: Update to 2.1.14....Marius Bakke 2018-06-28gnu: samba: Update to 4.8.3....Marius Bakke 2018-06-27gnu: samba: Return #t from all phases....Tobias Geerinckx-Rice 2018-06-27gnu: cifs-utils: Return #t from all phases....Tobias Geerinckx-Rice 2018-06-16gnu: ldb: Fix build on 32-bit systems....Marius Bakke 2018-06-11gnu: ldb: Delete bundled libraries from the source....Marius Bakke 2018-06-11gnu: ldb: Update to 1.4.0....Marius Bakke 2018-05-27Merge branch 'master' into core-updatesMark H Weaver 2018-05-26gnu: samba: Update to 4.8.2....Marius Bakke 2018-05-06Merge branch 'master' into core-updatesMarius Bakke 2018-05-03gnu: ldb: Update to 1.3.3....Marius Bakke 2018-05-03gnu: samba: Update to 4.8.1....Marius Bakke 2018-05-03gnu: samba: Propagate some inputs....Marius Bakke 2018-04-21Merge branch 'master' into core-updatesMark H Weaver 2018-04-18gnu: samba: Update to 4.7.7....Marius Bakke 2018-04-12gnu: iniparser: Return #t from all phases....Mark H Weaver 2018-04-06gnu: talloc: Update to 2.1.13....Marius Bakke 2018-03-22gnu: talloc: Update to 2.1.12....Marius Bakke 2018-03-15gnu: cifs-utils: Update to 6.8....Tobias Geerinckx-Rice 2018-03-14gnu: samba: Update to 4.7.6 [fixes CVE-2018-1050 and CVE-2018-1057]....Marius Bakke 2018-02-28gnu: ldb: Update to 1.3.2....Marius Bakke 2018-02-23gnu: tevent: Update to 0.9.36....Marius Bakke 2018-02-09gnu: samba: Update to 4.7.5....Marius Bakke 2018-02-01gnu: tevent: Update to 0.9.35....Marius Bakke 2018-02-01gnu: ldb: Update to 1.3.1....Marius Bakke 2018-01-15gnu: talloc: Update to 2.1.11....Tobias Geerinckx-Rice 2018-01-15gnu: iniparser: Update to 4.1....Tobias Geerinckx-Rice 2018-01-15gnu: iniparser: Use INSTALL-FILE....Tobias Geerinckx-Rice 2018-01-15gnu: iniparser: Use #:make-flags....Tobias Geerinckx-Rice 2018-01-15gnu: iniparser: Fix documentation directory....Tobias Geerinckx-Rice 2018-01-09gnu: samba: Update to 4.7.4....Marius Bakke 2017-11-21gnu: samba: Update to 4.7.3 [fixes CVE-2017-14746 and CVE-2017-15275]....Marius Bakke 2017-11-19gnu: samba: Update to 4.7.2....Marius Bakke 2017-11-19gnu: tevent: Update to 0.9.34....Marius Bakke 2017-11-04gnu: samba: Update to 4.7.1....Marius Bakke 2017-11-04gnu: ldb: Update to 1.3.0....Marius Bakke 2017-09-27gnu: samba: Install manual pages....Marius Bakke 2017-09-20gnu: samba: Update to 4.6.8....Marius Bakke 2017-09-04gnu: Put autoconf-related phases immediately after the 'unpack phase....Kei Kebreau 2017-08-10gnu: samba: Update to 4.6.7....Marius Bakke