aboutsummaryrefslogtreecommitdiff
Revert the following commit to work around a bootstrap comparison failure on
ARMv7, as reported at <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=71399>.

commit f6ab85b7049a03962ea98924d00802da357a1ad3
Author: renlin <renlin@138bc75d-0d04-0410-961f-82ee72b054a4>
Date:   Wed Dec 2 14:06:31 2015 +0000

    [PR67383][ARM][4.9]Backport of "Allow any register for DImode values in Thumb2"
    
    This partially fix PR67383. It allows the reload more flexibility to choose
    spilling pseudo registers.
    
    
    gcc/ChangeLog:
    
    2015-12-02  Renlin Li  <renlin.li@arm.com>
    
            Backport from mainline.
            2014-04-22  Ramana Radhakrishnan <ramana.radhakrishnan@arm.com>
    
            * config/arm/arm.c (arm_hard_regno_mode_ok): Loosen
            restrictions on core registers for DImode values in Thumb2.
    
    
    git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/branches/gcc-4_9-branch@231177 138bc75d-0d04-0410-961f-82ee72b054a4

diff --git a/gcc/config/arm/arm.c b/gcc/config/arm/arm.c
index 8ba6060..d9028a1 100644
--- b/gcc/config/arm/arm.c
+++ a/gcc/config/arm/arm.c
@@ -22624,19 +22624,12 @@
     }
 
   /* We allow almost any value to be stored in the general registers.
-     Restrict doubleword quantities to even register pairs in ARM state
-     so that we can use ldrd.  Do not allow very large Neon structure
-     opaque modes in general registers; they would use too many.  */
+     Restrict doubleword quantities to even register pairs so that we can
+     use ldrd.  Do not allow very large Neon structure opaque modes in
+     general registers; they would use too many.  */
   if (regno <= LAST_ARM_REGNUM)
-    {
-      if (ARM_NUM_REGS (mode) > 4)
-	  return FALSE;
-
-      if (TARGET_THUMB2)
-	return TRUE;
-
-      return !(TARGET_LDRD && GET_MODE_SIZE (mode) > 4 && (regno & 1) != 0);
-    }
+    return !(TARGET_LDRD && GET_MODE_SIZE (mode) > 4 && (regno & 1) != 0)
+      && ARM_NUM_REGS (mode) <= 4;
 
   if (regno == FRAME_POINTER_REGNUM
       || regno == ARG_POINTER_REGNUM)
b....* gnu/packages/c.scm (c-rrb): New variable. Liliana Marie Prikler 2023-05-11gnu: Add ISPC....* gnu/packages/c.scm (ispc): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> zamfofex 2023-04-01gnu: utf8-h: Install header under include/utf8 prefix....This is to standardize with the usage of the library in the package's only current user, OpenBoardView. It also matches the installation layout of the Arch package, which is made by its author. * gnu/packages/c.scm (utf8-h) [arguments]: Use gexps. Adjust installation prefix to 'include/utf8' in install phase. * gnu/packages/electronics.scm (openboardview) [arguments]: Delete fix-utf8-include-directive phase. Maxim Cournoyer 2023-04-01gnu: Add orangeduck-mpc....* gnu/packages/c.scm (orangeduck-mpc): New variable. * gnu/packages/patches/orangeduck-mpc-fix-pkg-config.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Maxim Cournoyer 2023-02-16gnu: Remove unneeded module imports....* gnu/packages/abiword.scm, * gnu/packages/ada.scm, * gnu/packages/agda.scm, * gnu/packages/backup.scm, * gnu/packages/barrier.scm, * gnu/packages/bioinformatics.scm, * gnu/packages/bootstrap.scm, * gnu/packages/bqn.scm, * gnu/packages/c.scm, * gnu/packages/chemistry.scm, * gnu/packages/coq.scm, * gnu/packages/cross-base.scm, * gnu/packages/databases.scm, * gnu/packages/emacs-xyz.scm, * gnu/packages/enlightenment.scm, * gnu/packages/games.scm, * gnu/packages/geo.scm, * gnu/packages/ghostscript.scm, * gnu/packages/gl.scm, * gnu/packages/golang.scm, * gnu/packages/jami.scm, * gnu/packages/java-maths.scm, * gnu/packages/kde-frameworks.scm, * gnu/packages/kde-plasma.scm, * gnu/packages/language.scm, * gnu/packages/libreoffice.scm, * gnu/packages/linphone.scm, * gnu/packages/lisp.scm, * gnu/packages/llvm.scm, * gnu/packages/machine-learning.scm, * gnu/packages/minetest.scm, * gnu/packages/monitoring.scm, * gnu/packages/nfs.scm, * gnu/packages/ocr.scm, * gnu/packages/opencl.scm, * gnu/packages/pdf.scm, * gnu/packages/python-xyz.scm, * gnu/packages/racket.scm, * gnu/packages/rust.scm, * gnu/packages/syncthing.scm, * gnu/packages/syndication.scm, * gnu/packages/telegram.scm, * gnu/packages/vulkan.scm, * gnu/packages/web-browsers.scm, * gnu/packages/web.scm, * gnu/packages/webkit.scm: Remove some unecessary module imports. Efraim Flashner 2023-02-11gnu: qbe: Update to 1.1....* gnu/packages/c.scm (qbe): Update to 1.1. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> jgart 2023-01-31gnu: c-intro-and-ref: Update to 0.0.0-1.47e5a23....* gnu/packages/c.scm (c-intro-and-ref): Update to commit 47e5a234a7c0. Signed-off-by: Christopher Baines <mail@cbaines.net> Hilton Chain 2023-01-22gnu: libhx: Update to 4.9....* gnu/packages/c.scm (libhx): Update to 4.9. Tobias Geerinckx-Rice 2023-01-15gnu: mimalloc: Update to 2.0.9....* gnu/packages/c.scm (mimalloc): Update to 2.0.9. Tobias Geerinckx-Rice