aboutsummaryrefslogtreecommitdiff
From f0065f207cf19cd960b33d961472c6d69514336f Mon Sep 17 00:00:00 2001
From: Samuel Thibault <samuel.thibault@gnu.org>
Date: Fri, 7 Oct 2022 22:45:06 +0200
Subject: [PATCH] libstdc++: Mark pieces of gnu-linux/os_support.h
 linux-specific

This is notably needed because in glibc 2.34, the move of pthread functions
into libc.so happened for Linux only, not GNU/Hurd.

The pthread_self() function can also always be used fine as it is on
GNU/Hurd.

libstdc++-v3/ChangeLog:

	* config/os/gnu-linux/os_defines.h [!__linux__]
	(_GLIBCXX_NATIVE_THREAD_ID, _GLIBCXX_GTHREAD_USE_WEAK): Do not define.

Reviewed-by: Jonathan Wakely <jwakely@redhat.com>
---
 libstdc++-v3/config/os/gnu-linux/os_defines.h | 22 +++++++++++--------
 1 file changed, 13 insertions(+), 9 deletions(-)

diff --git a/libstdc++-v3/config/os/gnu-linux/os_defines.h b/libstdc++-v3/config/os/gnu-linux/os_defines.h
index 3064f8d908ac2..87317031fcd71 100644
--- a/libstdc++-v3/config/os/gnu-linux/os_defines.h
+++ b/libstdc++-v3/config/os/gnu-linux/os_defines.h
@@ -60,22 +60,26 @@
 # define _GLIBCXX_HAVE_FLOAT128_MATH 1
 #endif
 
-#if __GLIBC_PREREQ(2, 27)
+#ifdef __linux__
+// The following libpthread properties only apply to Linux, not GNU/Hurd.
+
+# if __GLIBC_PREREQ(2, 27)
 // Since glibc 2.27 pthread_self() is usable without linking to libpthread.
-# define _GLIBCXX_NATIVE_THREAD_ID pthread_self()
-#else
+#  define _GLIBCXX_NATIVE_THREAD_ID pthread_self()
+# else
 // Before then it was in libc.so.6 but not libc.a, and always returns 0,
 // which breaks the invariant this_thread::get_id() != thread::id{}.
 // So only use it if we know the libpthread version is available.
 // Otherwise use (__gthread_t)1 as the ID of the main (and only) thread.
-# define _GLIBCXX_NATIVE_THREAD_ID \
-  (__gthread_active_p() ? __gthread_self() : (__gthread_t)1)
-#endif
+#  define _GLIBCXX_NATIVE_THREAD_ID \
+   (__gthread_active_p() ? __gthread_self() : (__gthread_t)1)
+# endif
 
-#if __GLIBC_PREREQ(2, 34)
+# if __GLIBC_PREREQ(2, 34)
 // Since glibc 2.34 all pthreads functions are usable without linking to
 // libpthread.
-# define _GLIBCXX_GTHREAD_USE_WEAK 0
-#endif
+#  define _GLIBCXX_GTHREAD_USE_WEAK 0
+# endif
+#endif // __linux__
 
 #endif
he closure size returned by: guix size $(guix system build gnu/system/install.scm) from 1.6G to 1.5G. * gnu/system/locale.scm (%default-locale-libcs): Remove GLIBC-2.29. Ludovic Courtès 2020-09-20gnu: glibc: Add version 2.31....* gnu/packages/base.scm (glibc-2.31): New variable. * gnu/system/locale.scm (%default-locale-libcs): Add it. Ludovic Courtès 2020-08-26system: locale: Only use the current glibc....Only use the current glibc, as adding glibc-2.29 for compatibility adds ~100MiB to the barebones system closure. * gnu/system/locale.scm (%default-locale-libcs): Remove glibc-2.29. Mathieu Othacehe 2020-05-15locale: Use the native gzip and libc when building locales....This fixes system cross-compilation. * gnu/system/locale.scm (single-locale-directory)[build]: Use the native GZIP and LIBC. Ludovic Courtès 2020-05-03locale: Add glibc 2.29 to '%default-locale-libcs'....This eases transition for anyone reconfiguring and still having profiles with packages using the former libc. * gnu/system/locale.scm (%default-locale-libcs): Add GLIBC-2.29. Ludovic Courtès 2020-02-12system: locale: Remove canonical-package call....This is a follow-up of dfc8ccbf5da96a67eb1cade499f0def21e7fdb02. Building locales using the same glibc as the one programs are linked against is enough. * gnu/system/locale.scm (%default-locale-libcs): Use the plain glibc package. Mathieu Othacehe 2020-02-11system: Stop using canonical-package....Usage of canonical-package outside of thunked fields breaks cross-compilation, see: https://lists.gnu.org/archive/html/guix-devel/2019-12/msg00410.html. * gnu/installer.scm (installer-program): Remove canonical-package. * gnu/services/base.scm (<nscd-cache>): Ditto, (%base-services): ditto. * gnu/services/xorg.scm: Remove useless canonical-package import. * gnu/system.scm (%base-packages): Remove canonical-package. * gnu/system/install.scm (%installation-services): Ditto, (installation-os): ditto. * gnu/system/locale.scm (single-locale-directory): Ditto. Mathieu Othacehe 2019-06-07Add (gnu build locale)....* gnu/build/locale.scm: New file. * gnu/local.mk (MODULES_NOT_COMPILED): Add it. * gnu/installer/locale.scm (normalize-codeset): Remove. * gnu/system/locale.scm (localedef-command): Remove. (single-locale-directory): Use (gnu build locale). (glibc-supported-locales)[build]: Likewise, and remove 'read-supported-locales'. Ludovic Courtès 2019-05-13locale: Add 'glibc-supported-locales'....* gnu/system/locale.scm (glibc-supported-locales): New procedure. Ludovic Courtès 2018-01-24system: Put locales where libc will find them....* gnu/system/locale.scm (localedef-command, single-locale-directory): Use only the major+minor part of the libc version number in the locale directory name. Mark H Weaver 2017-07-17locale: Demonadify the locale creation API....* gnu/system/locale.scm (single-locale-directory): Use 'computed-file' instead of 'gexp->derivation'. (locale-directory): Adjust accordingly and do the same. * gnu/system.scm (operating-system-directory-base-entries): Adjust accordingly. Ludovic Courtès 2017-07-17gnu: Remove glibc@2.21 and its traces....* gnu/packages/base.scm (glibc-2.21): Remove. * gnu/system/locale.scm (localedef-command)[maybe-version-directory]: Remove. Replace call with use of 'package-version'. (single-locale-directory): Remove 'version>=' conditional. Ludovic Courtès 2017-07-11system: Refer to native packages when appropriate....* gnu/system/locale.scm (localedef-command): Use the native LIBC. * gnu/system/shadow.scm (default-skeletons): Use the native GUILE-WM. Ludovic Courtès